aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3be2d0dae5..86665b0af4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25230,17 +25230,17 @@ they use the same path.")
(define-public python-blosc
(package
(name "python-blosc")
- (version "1.5.1")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "blosc" version))
(sha256
(base32
- "1cm91c6r431yla2mbs4895bgiianjf30dfz14vvv99dslygd65jw"))
+ "0xmjs28sgpnb940zrhw010dq2m9d8a5h4fgnjyk6645fgfr1j8f2"))
(snippet
#~(begin (use-modules (guix build utils))
- (delete-file-recursively "c-blosc")))))
+ (delete-file-recursively "blosc/c-blosc")))))
(build-system python-build-system)
;; FIXME: all tests pass, but then this error is printed:
;; TypeError: calling <function run at 0x7ffff2568d90> returned None, not a test
@@ -25250,9 +25250,10 @@ they use the same path.")
#~(modify-phases %standard-phases
(add-after 'unpack 'find-blosc
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "BLOSC_DIR" #$(this-package-input "c-blosc")))))))
+ (setenv "USE_SYSTEM_BLOSC" "1")
+ (setenv "Blosc_ROOT" #$(this-package-input "c-blosc")))))))
(propagated-inputs
- (list python-numpy))
+ (list python-scikit-build python-numpy))
(inputs (list c-blosc))
(home-page "https://github.com/blosc/python-blosc")
(synopsis "Python wrapper for the Blosc data compressor library")