aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 1ae9512df1..19c15358c0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1711,11 +1711,16 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(substitute* "man/man1/Makefile.in"
(("^man_MANS = ngspice\\.1 ngnutmeg\\.1 ngsconvert\\.1 ngmultidec\\.1")
"man_MANS = "))))
- (add-after 'install 'delete-script-files
+ (add-after 'install 'delete-scripts-and-config
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
(string-append (assoc-ref outputs "out")
- "/share/ngspice/scripts")))))
+ "/share/ngspice/scripts"))
+ ;; This file is autogenerated by the configure script and should
+ ;; not be distributed. It could be removed in ngspice 35. See
+ ;; https://bugs.archlinux.org/task/70569 for reference.
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/include/config.h")))))
#:configure-flags
(list "--enable-openmp"
"--enable-ciderlib"
oxygen....Mark H Weaver 2016-03-26gnu: crossguid: Set explicit file name for source checkout....David Thompson 2016-03-19gnu: kodi: Remove @acronym from description....Ludovic Courtès 2016-03-14gnu: kodi: Update to 16.0....David Thompson 2016-03-14gnu: Add crossguid....David Thompson 2016-01-06gnu: Add and use default IcedTea....Ricardo Wurmus 2015-11-25gnu: Add kodi....David Thompson