aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/graphics.scm12
2 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2c16e33292..af46d352ee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7257,6 +7257,10 @@ almost all of them.")
(replace 'check
(lambda* (#:key parallel-tests? tests? #:allow-other-keys)
(when tests?
+ (setenv "XDG_RUNTIME_DIR" (string-append (getcwd)
+ "/runtime-dir"))
+ (mkdir (getenv "XDG_RUNTIME_DIR"))
+ (chmod (getenv "XDG_RUNTIME_DIR") #o700)
(setenv "MESON_TESTTHREADS"
(if parallel-tests?
(number->string (parallel-job-count))
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a0d7ec8df1..f112af57b3 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1350,7 +1350,17 @@ with strong support for multi-part, multi-channel use cases.")
(arguments
(list #:tests? #f ; half the tests require online data or use redirection
#:configure-flags #~(list "-DUSE_EXTERNAL_PUGIXML=1"
- "-DOIIO_BUILD_TESTS=false")))
+ "-DOIIO_BUILD_TESTS=false")
+ #:phases
+ #~(modify-phases %standard-phases
+ ; Work around a CMake Zlib-detection bug:
+ ; https://issues.guix.gnu.org/72046
+ ; https://gitlab.kitware.com/cmake/cmake/-/issues/25200
+ (add-after 'configure 'fix-zlib-version
+ (lambda _
+ (substitute* "include/imageio_pvt.h"
+ (("#define ZLIB_VERSION \"1\\.3\"")
+ "")))))))
(native-inputs
(list pkg-config))
(inputs