aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/plotutils-spline-test.patch34
-rw-r--r--gnu/packages/plotutils.scm7
3 files changed, 41 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e574697f32..8274e158d0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1408,6 +1408,7 @@ dist_patch_DATA = \
%D%/packages/patches/plink-endian-detection.patch \
%D%/packages/patches/plib-CVE-2011-4620.patch \
%D%/packages/patches/plib-CVE-2012-4552.patch \
+ %D%/packages/patches/plotutils-spline-test.patch \
%D%/packages/patches/podofo-cmake-3.12.patch \
%D%/packages/patches/portaudio-audacity-compat.patch \
%D%/packages/patches/portmidi-modular-build.patch \
diff --git a/gnu/packages/patches/plotutils-spline-test.patch b/gnu/packages/patches/plotutils-spline-test.patch
new file mode 100644
index 0000000000..2f9feb96cf
--- /dev/null
+++ b/gnu/packages/patches/plotutils-spline-test.patch
@@ -0,0 +1,34 @@
+Description: Work around i386 testsuite error
+Author: Andreas Metzler <ametzler@debian.org>
+Origin: vendor
+Bug: http://lists.gnu.org/archive/html/bug-plotutils/2017-02/msg00001.html
+Bug-Debian: https://bugs.debian.org/856134
+Forwarded: http://lists.gnu.org/archive/html/bug-plotutils/2017-02/msg00002.html
+Last-Update: 2017-02-25
+
+--- a/test/spline.test
++++ b/test/spline.test
+@@ -3,12 +3,21 @@
+ echo 0 1 0.5 0.75 -0.25 0 | ../spline/spline -a -T 1 -n 120 \
+ --precision 5 -p >spline.out
+
++# Work around testsuite error
++# http://lists.gnu.org/archive/html/bug-plotutils/2016-04/msg00000.html
++#
+ # work around line end problems in installations with DJGPP under DOS
+-tr -d '\015' < spline.out > spline.dos
++tr -d '\015' < spline.out \
++ | head -n 120 | tail -n 119 \
++ > spline.dos
+
+-if cmp -s $SRCDIR/spline.xout spline.dos
++# cannot patch spline.xout, it is used as input for graph.test.
++head -n 120 $SRCDIR/spline.xout | tail -n 119 > spline.xout.4comp
++
++if cmp -s spline.xout.4comp spline.dos
+ then retval=0;
+ else retval=1;
+ fi;
+
++rm -f spline.xout.4comp
+ exit $retval
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 8ddc8ebc74..1e182fbb51 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -73,7 +73,12 @@
(substitute* "libplot/z_write.c"
(("png_ptr->jmpbuf")
"png_jmpbuf (png_ptr)"))
- #t))))
+ #t))
+ (patches
+ ;; The test suite fails on some architectures such as i686 (see:
+ ;; https://lists.gnu.org/archive/html/bug-plotutils/2016-04/msg00002.html).
+ ;; The following Debian patch works around it.
+ (search-patches "plotutils-spline-test.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-libplotter")))
s/mail.scm?id=d7f17c6a920e5bca89022ca766f6444782dc83d0'>gnu: msmtp: Update to 1.8.24....Timotej Lazar 2023-06-30gnu: opensmtpd: Update to 7.3.0p1....Tobias Geerinckx-Rice 2023-06-30gnu: opensmtpd: Build with OpenSSL....Tobias Geerinckx-Rice 2023-06-30gnu: Remove libasr....Tobias Geerinckx-Rice 2023-06-26gnu: aerc: Update to 0.15.2....guix-patches--- via 2023-06-24gnu: opensmtpd-filter-rspamd: Update to 0.1.8....Tobias Geerinckx-Rice 2023-06-18gnu: opensmtpd: Update to 7.3.0p0....Tobias Geerinckx-Rice 2023-06-20gnu: mu: Update to 1.10.3....Ricardo Wurmus 2023-06-12gnu: mailutils: Update to 3.16...Andy Tai 2023-06-04gnu: urlscan: Update to 1.0.0....Efraim Flashner 2023-05-24gnu: isync: Add patch to improve openssl-3 compatibility....Morgan Smith 2023-05-11gnu: mutt: Update to 2.2.10....Efraim Flashner 2023-05-06gnu: msmtp: Install old msmtpqueue scripts...Karl Hallsby 2023-04-30gnu: mumi: Add guile-gnutls to inputs....kiasoc5 2023-04-30gnu: opensmtpd-extras: Build with mariadb....Efraim Flashner 2023-04-28gnu: dovecot: Fix build....宋文武 2023-04-25gnu: libpst: Fix python detection....Efraim Flashner 2023-04-24gnu: mumi: Add bash-minimal to inputs....Arun Isaac 2023-04-24gnu: mumi: Update to 0.0.5-2.85d5efb....Arun Isaac 2023-04-24gnu: mumi: Move to Savannah....Arun Isaac 2023-04-11gnu: mu: Update to 1.10.2....Ricardo Wurmus 2023-04-02gnu: Add mairix....Martin Marshall