aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 02131f10d0..a81312b6a5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -54,16 +54,16 @@
(define-public java-swt
(package
(name "java-swt")
- (version "4.4.2")
+ (version "4.5")
(source (origin
(method url-fetch)
(uri (string-append
"http://ftp-stud.fht-esslingen.de/pub/Mirrors/"
"eclipse/eclipse/downloads/drops4/R-" version
- "-201502041700/swt-" version "-gtk-linux-x86.zip"))
+ "-201506032000/swt-" version "-gtk-linux-x86.zip"))
(sha256
(base32
- "0lzyqr8k2zm5s8fmnrx5kxpslxfs0i73y26fwfms483x45izzwj8"))))
+ "03mhzraikcs4fsz7d3h5af9pw1bbcfd6dglsvbk2ciwimy9zj30q"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("-f" "make_linux.mak")
d>system: Put locales where libc will find them....* gnu/system/locale.scm (localedef-command, single-locale-directory): Use only the major+minor part of the libc version number in the locale directory name. Mark H Weaver 2017-07-17locale: Demonadify the locale creation API....* gnu/system/locale.scm (single-locale-directory): Use 'computed-file' instead of 'gexp->derivation'. (locale-directory): Adjust accordingly and do the same. * gnu/system.scm (operating-system-directory-base-entries): Adjust accordingly. Ludovic Courtès 2017-07-17gnu: Remove glibc@2.21 and its traces....* gnu/packages/base.scm (glibc-2.21): Remove. * gnu/system/locale.scm (localedef-command)[maybe-version-directory]: Remove. Replace call with use of 'package-version'. (single-locale-directory): Remove 'version>=' conditional. Ludovic Courtès 2017-07-11system: Refer to native packages when appropriate....* gnu/system/locale.scm (localedef-command): Use the native LIBC. * gnu/system/shadow.scm (default-skeletons): Use the native GUILE-WM. Ludovic Courtès