aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 499920160a..c1f6c8ea5e 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1257,7 +1257,9 @@ AR100.")
;; The inputs are not propagated since qmk is to be used strictly as a
;; command.
(inputs
- (list (make-avr-toolchain)
+ ;; The 'qmk setup' command advises to use GCC at version 8, and there are
+ ;; compilation errors in some firmware otherwise.
+ (list (make-avr-toolchain #:xgcc gcc-8)
avrdude
dfu-programmer
git-minimal ;for the clone action