aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..2317cbec5a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -31,11 +31,14 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages qt)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages web))
(define-public breeze
(package
@@ -83,6 +86,30 @@
the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
(license license:gpl2+)))
+(define-public breeze-gtk
+ (package
+ (name "breeze-gtk")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name
+ "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+ (build-system qt-build-system)
+ (arguments
+ '(#:tests? #f)) ;no 'test' target
+ (native-inputs (list breeze extra-cmake-modules sassc python
+ python-pycairo))
+ (home-page "https://invent.kde.org/plasma/breeze")
+ (synopsis "Default KDE Plasma theme (GTK+ port)")
+ (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+ (license (list license:bsd-3 ;cmake/FindSass.cmake
+ license:lgpl2.1+)))) ;<all other files>
+
(define-public kdecoration
(package
(name "kdecoration")
cedure. (get-signature): Look for the 'issuer and 'issuer-fingerprint subpackets. Ensure the issuer key ID matches the fingerprint when both are available. (parse-subpackets): Handle SUBPACKET-ISSUER-FINGERPRINT. * tests/openpgp.scm (%rsa-key-fingerprint) (%dsa-key-fingerprint, %ed25519-key-fingerprint): New variables. * tests/openpgp.scm ("get-openpgp-detached-signature/ascii"): Check the result of 'openpgp-signature-issuer-fingerprint'. Ludovic Courtès 2020-05-04Add (guix openpgp)....* guix/openpgp.scm, tests/openpgp.scm, tests/civodul.key, tests/dsa.key, tests/ed25519.key, tests/rsa.key, tests/ed25519.sec: New files. * Makefile.am (MODULES): Add guix/openpgp.scm. (SCM_TESTS): Add tests/openpgp.scm. (EXTRA_DIST): Add tests/*.key and tests/ed25519.sec. Ludovic Courtès