aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3280aa15d6..9fa8ab3a23 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2464,13 +2464,13 @@ informative error messages when it's not available.")
(define-public r-devtools
(package
(name "r-devtools")
- (version "2.4.0")
+ (version "2.4.1")
(source (origin
(method url-fetch)
(uri (cran-uri "devtools" version))
(sha256
(base32
- "094kl4d07kvmn1dcvq73mn4r30c4vpshrqj4998azh7garjlz3kj"))))
+ "0jd4ph3z7shqyy8lw34i10qmhqr6z8ihqix96kkayjql315ccah6"))))
(build-system r-build-system)
(propagated-inputs
`(("r-callr" ,r-callr)
@@ -2479,7 +2479,6 @@ informative error messages when it's not available.")
("r-ellipsis" ,r-ellipsis)
("r-fs" ,r-fs)
("r-httr" ,r-httr)
- ("r-jsonlite" ,r-jsonlite)
("r-lifecycle" ,r-lifecycle)
("r-memoise" ,r-memoise)
("r-pkgbuild" ,r-pkgbuild)
class='add'>+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_purchase_secondary_unit" version))
+ (sha256
+ (base32 "0vyvdrshlikp9m3gxn1yyi15qxgih0cccxndr9d257fap9nilip5"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "purchase_secondary_unit"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-account-invoice-secondary-unit"
+ ,trytond-account-invoice-secondary-unit)
+ ("trytond-stock-secondary-unit" ,trytond-stock-secondary-unit)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-product" ,trytond-product)
+ ("trytond-purchase" ,trytond-purchase)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-purchase-secondary-unit")
+ (synopsis "Tryton module to add a secondary unit on purchase line")
+ (description "The @emph{Purchase Secondary Unit} Tryton module adds a
+secondary unit of measure on purchase lines.
+
+The secondary quantity and unit price are kept synchronized with the quantity
+and unit price. The secondary unit is defined on the product supplier or on
+the product with its factor against the purchase unit.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")