aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fe024228f3..bb5196b9f2 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4705,7 +4705,28 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
license:freebsd-doc)))) ; documentation
(define-public python2-feedparser
- (package-with-python2 python-feedparser))
+ (package
+ (name "python2-feedparser")
+ (version "5.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "feedparser" version ".tar.bz2"))
+ (sha256
+ (base32
+ "00hb4qg2am06g81mygfi1jsbx8830024jm45g6qp9g8fr6am91yf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:python ,python-2))
+ (home-page
+ "https://github.com/kurtmckee/feedparser")
+ (synopsis "Parse feeds in Python")
+ (description
+ "Universal feed parser which handles RSS 0.9x, RSS 1.0, RSS 2.0,
+CDF, Atom 0.3, and Atom 1.0 feeds.")
+ (license (list license:bsd-2 ; source code
+ license:freebsd-doc)))) ; documentation
(define-public guix-data-service
(let ((commit "df2a0a73f1f35ea53ba6c07a6ad4c5347ba12b8f")
itle='2019-04-05 15:39:35 +0200'>2019-04-05services: dbus: Add 'wrapped-dbus-service'....* gnu/services/desktop.scm (wrapped-dbus-service): Move to... * gnu/services/dbus.scm (wrapped-dbus-service): ... here. New procedure. Ludovic Courtès 2019-03-08activation: Shared system home directories are now 555 and root-owned....Fixes <https://bugs.gnu.org/34788>. Reported by Jack Hill <jackhill@jackhill.us>. Regression introduced by the combination of 8bb76f3d44c1f5ffec8011819494db306a51d801 and 0ae735bcc8ff7fdc89d67b492bdee9091ee19e86: /var/empty would be 700 and owned by one of the system accounts (thus inaccessible to others), and /var/run/dbus would be 700 as well, thereby preventing D-Bus clients from connecting to the daemon. * gnu/build/activation.scm (duplicates): New procedure. (activate-users+groups)[system-accounts]: New variable. Use it. Make shared system account home directories #o555 and root-owned. * gnu/services/dbus.scm (dbus-activation): Make /var/run/dbus #o755. * gnu/tests/base.scm (run-basic-test): Test the ownership and permissions of /var/empty. Ludovic Courtès 2018-05-20services: dbus: Search more directories for '.service' files....* gnu/services/dbus.scm (system-service-directory): Remove one level of directories when searching for '.service' files. Efraim Flashner