aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-build.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index bb608dc568..aa113dd16b 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -637,6 +637,36 @@ cancelation for groups of goroutines working on subtasks of a common task
support for low-level interaction with the operating system.")
(license license:bsd-3)))
+(define-public go-golang-org-x-telemetry
+ (package
+ (name "go-golang-org-x-telemetry")
+ (version "0.0.0-20240912191618-22fe4a1e7b9c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/telemetry")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05gvxiv0yqfclckm2ysavbfy1jpz8v71r2glrcvhjq8wzw90g9gz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-skip" "TestStart|TestConcurrentStart")
+ #:import-path "golang.org/x/telemetry"))
+ (propagated-inputs
+ (list go-golang-org-x-mod
+ go-golang-org-x-sync
+ go-golang-org-x-sys))
+ (home-page "https://go.googlesource.com/telemetry")
+ (synopsis "Go Telemetry")
+ (description
+ "This repository holds the Go Telemetry server code and libraries, used
+for hosting @url{https://telemetry.go.dev,telemetry.go.dev} and instrumenting
+Go toolchain programs with opt-in telemetry.")
+ (license license:bsd-3)))
+
(define-public go-golang-org-x-term
(package
(name "go-golang-org-x-term")
2023-10-05Revert "system: accounts: Export <user-account>."...This reverts commit 03795e2ba27424fc98957da00f6c71325e7ae425. Fixes <https://issues.guix.gnu.org/66279>. Ludovic Courtès 2023-08-20Revert "gnu: system: Add home-directory-permissions field to <user-account>."...This reverts commit e9a5eebc785cb843034b38c5c5a6dd10904bdf2a, which as far as I can tell breaks system roll-backs thusly: [...] In gnu/build/accounts.scm: 239:27 3 (_ #<<password-entry> name: "root" password: "x" uid: 0 gid: 0 real-name: "System >) In unknown file: 2 (string-join ("root" "x" "0" "0" "System administrator" "/root" #t) ":" #<undefined>) In ice-9/boot-9.scm: 1685:16 1 (raise-exception _ #:continuable? _) 1685:16 0 (raise-exception _ #:continuable? _) ice-9/boot-9.scm:1685:16: In procedure raise-exception: In procedure string-append: Wrong type (expecting string): #t Tobias Geerinckx-Rice 2023-08-25gnu: system: Add home-directory-permissions field to <user-account>....* gnu/system/accounts.scm (<user-account>)[home-directory-permissions]: New field. (user-account-home-directory-permissions): New accessor. * gnu/build/activation.scm (activate-users+groups): Use home directory permission bits from the user account object. * doc/guix.texi (User Accounts): Document new field. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz> David Thompson 2023-07-26system: accounts: Export <user-account>.Maxim Cournoyer