aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ee945fcc68..fe822e8311 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1816,29 +1816,27 @@ written in C++.")
(license license:boost1.0)))
(define-public zug
- (let ((commit "d7e814b45fceceee3cb1442997d8b46cee4764ec")
- (revision "0"))
- (package
- (name "zug")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/arximboldi/zug")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ww4prh763n81kzzijak8z495varlvqml4ip7i09klqnw6ya72fc"))
- (modules '((guix build utils)))
- (snippet #~(delete-file-recursively "tools"))))
- (build-system cmake-build-system)
- (arguments (list #:test-target "check"))
- (native-inputs (list boost catch2))
- (home-page "https://sinusoid.es/zug")
- (synopsis "Higher-order sequence transformers")
- (description "Zug is a C++ library providing transducers, that is,
+ (package
+ (name "zug")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arximboldi/zug")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06vsbzx4ripidpb6ia7y1y8pmjk6gxzr93ilby90ahj6p2x08baf"))
+ (modules '((guix build utils)))
+ (snippet #~(delete-file-recursively "tools"))))
+ (build-system cmake-build-system)
+ (arguments (list #:test-target "check"))
+ (native-inputs (list boost catch2))
+ (home-page "https://sinusoid.es/zug")
+ (synopsis "Higher-order sequence transformers")
+ (description "Zug is a C++ library providing transducers, that is,
composable sequential transformations.")
- (license license:boost1.0))))
+ (license license:boost1.0)))
(define-public lager
(let ((commit "2016df38be90ee176bcb73ea414be2318bc1ef31")