aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 177ab8a20f..0ef4c46d9f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8399,36 +8399,22 @@ library.")
(define-public go-chroma
(package
+ (inherit go-github-com-alecthomas-chroma-v2)
(name "go-chroma")
- (version "2.14.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/chroma")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qgr4gywjks869sc85wb8nby612b8wvsa1dwpsbanjsljq7wq7mp"))))
- (build-system go-build-system)
(arguments
(list
#:install-source? #f
- #:import-path "github.com/alecthomas/chroma/cmd/chroma"))
+ #:import-path "github.com/alecthomas/chroma/cmd/chroma"
+ #:unpack-path "github.com/alecthomas/chroma"))
(native-inputs
(list go-github-com-alecthomas-assert-v2
- go-github-com-alecthomas-chroma-v2
go-github-com-alecthomas-kong
go-github-com-mattn-go-colorable
go-github-com-mattn-go-isatty))
- (home-page "https://github.com/alecthomas/chroma")
- (synopsis "General purpose syntax highlighter in pure Golang")
(description
(string-append (package-description go-github-com-alecthomas-chroma-v2)
" This package provides an command line interface (CLI)
-tool."))
- (license license:asl2.0)))
+tool."))))
(define-public go-hclogvet
(package