aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/upnp.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
new file mode 100644
index 0000000000..a1a18d272c
--- /dev/null
+++ b/gnu/packages/upnp.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages upnp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public miniupnpc
+ (package
+ (name "miniupnpc")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://miniupnp.tuxfamily.org/files/miniupnpc-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0r24jdqcyf839n30ppimdna0hvybscyziaad7ng99fw0x19y88r9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("python" ,python-2)))
+ (arguments
+ ;; The build system does not use a configure script but depends on
+ ;; `make'. Hence we should pass parameters to `make' instead and remove
+ ;; the configure phase.
+ '(#:make-flags
+ (list
+ (string-append
+ "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
+ (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (alist-delete 'configure %standard-phases)))
+ (home-page "http://miniupnp.free.fr/")
+ (synopsis "Library implementing the client side UPnP protocol")
+ (description
+ "MiniUPnPc is a library is useful whenever an application needs to listen
+for incoming connections but is run behind a UPnP enabled router or firewall.
+Examples for such applications include: P2P applications, FTP clients for
+active mode, IRC (for DCC) or IM applications, network games, any server
+software.")
+ (license
+ (x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
a href='/guix/commit/gnu/services/messaging.scm?id=19ff1f2687ab5ceeee6335dce2794590d0f4aa27'>services: configuration: Show default values of list types.Clément Lassieur * doc/guix.texi (Messaging Services): Regenerate it. * gnu/services/configuration.scm (show-default?): Check VAL rather than DEFAULT. * gnu/services/messaging.scm (show-default?): Check VAL rather than DEFAULT. (prosody-configuration)[modules-enabled]: Remove default value from docstring. 2017-11-26services: prosody: Add support for disable-sasl-mechanisms.Clément Lassieur * doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[disable-sasl-mechanisms]: New field. 2017-11-26services: prosody: Allow to add raw content to the config file.Clément Lassieur * doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[raw-content]: New field. (raw-content?, serialize-raw-content): New procedures. 2017-11-26services: prosody: Add support for http-max-content-size.Clément Lassieur * doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[http-max-content-size]: New field. 2017-11-26services: prosody: Add support for http-external-url.Clément Lassieur * doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[http-external-url]: New field. 2017-11-26services: prosody: Adapt to Prosody 0.10.0.Clément Lassieur * doc/guix.texi (Messaging Services): Add "mam" as a module example. Document 'prosodyctl check'. Replace 'prosodyctl cert request' with 'prosodyctl cert import'. Regenerate it. * gnu/services/messaging.scm (serialize-module-list): Remove "posix" from the default modules list because it is now automatically loaded. (ssl-configuration)[key, certificate]: Remove them because they are now automatically located. Fix their docstrings. (%default-modules-enabled): Add "carbons" and "blocklist". (prosody-configuration)[certificates]: Set default directory from which certificates/keys will be automatically located. 2017-03-24services: Factorize define-maybe macro.Mathieu Othacehe * gnu/services/configuration.scm (id): New procedure extracted from define-configuration. (define-maybe): New exported procedure, moved from messaging.scm. * gnu/services/messaging.scm (define-maybe): Remove it. (id): Move declaration inside define-all-configurations which is now the only caller procedure. Signed-off-by: Clément Lassieur <clement@lassieur.org> 2017-03-08services: prosody: Use 'id' to introduce unhygienic top-level identifiers.Ludovic Courtès * gnu/services/messaging.scm (define-all-configurations): Use 'id' to introduce raw/literal/unhygienic top-level identifiers. Fixes compilation with Guile 2.2. 2017-03-08services: prosody: Make sure 'id' is available at expansion time.Ludovic Courtès * gnu/services/messaging.scm (id): Use 'define-syntax-rule' instead of 'define' to make sure 'id' is available at expansion time. 2017-02-10tests: Add 'prosody-service-type' test.Clément Lassieur * gnu/tests/messaging.scm: New file. * gnu/services/messaging.scm: New exported procedure. (<shepherd-service>)[provision]: Add 'xmpp-daemon'. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-01-23services: prosody: Fix activation script.Clément Lassieur * gnu/services/messaging.scm (prosody-activation): Import (guix build utils) for 'mkdir-p'. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-01-08gnu: Add Prosody service.Clément Lassieur * gnu/services/messaging.scm: New file. * gnu/services/configuration.scm: New exported procedures. * gnu/local.mk (GNU_SYSTEM_MODULES): Add gnu/services/messaging.scm. * doc/guix.texi (Messaging Services): New section. Signed-off-by: Ludovic Courtès <ludo@gnu.org>