aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-systemtools.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index b79f72a4ed..809a9ddb7a 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -160,7 +160,17 @@ Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
qtbase-5
xapian))
(arguments
- `(#:tests? #f)) ;; 1/1 test fails
+ `(#:tests? #f ;; 1/1 test fails
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ ;; Since qt-wrap selectors do not wrap for /share/kf5
+ ;; directories, we need this so khelpcenter can find html4.css.
+ (wrap-program (string-append out "/bin/khelpcenter")
+ `("XDG_DATA_DIRS" suffix
+ (,(string-append (assoc-ref inputs "khtml") "/share"))))))))))
(home-page "https://apps.kde.org/khelpcenter/")
(synopsis "KDE documentation viewer")
(description "KHelpCenter uses meta data files which describe the