index
:
guix
koszko
koszko-scripts
Wojtek's customized Guix
about
summary
refs
log
tree
commit
diff
log msg
author
committer
range
;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 David Thompson <davet@gnu.org> ;;; Copyright © 2016 David Craven <david@craven.ch> ;;; Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org> ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net> ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev> ;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il> ;;; Copyright © 2023 David Elsing <david.elsing@posteo.net> ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (test-crate) #:use-module (guix import crate) #:use-module (guix base32) #:use-module (guix build-system cargo) #:use-module ((gcrypt hash) #:select ((sha256 . gcrypt-sha256))) #:use-module (guix packages) #:use-module (guix read-print) #:use-module (guix tests) #:use-module (gnu packages) #:use-module (ice-9 iconv) #:use-module (ice-9 match) #:use-module (srfi srfi-64)) ;; crate versions and dependencies used here ;; foo-0.8.1 ;; foo-1.0.0 ;; foo-1.0.3 ;; leaf-alice 0.7.5 ;; bar-1.0.0 ;; leaf-bob 3.0.1 ;; leaf-bob 3.0.2 (dev-dependency) ;; leaf-bob 4.0.0 (dev-dependency) ;; ;; root-1.0.0 ;; root-1.0.4 ;; intermediate-a 1.0.42 ;; intermediate-b ^1.0.0 ;; leaf-alice ^0.7 ;; leaf-bob ^3 ;; intermediate-c 1 (dev-dependency) ;; ;; intermediate-a-1.0.40 ;; intermediate-a-1.0.42 ;; intermediate-a-1.1.0-alpha.1 ;; intermediate-a 1.2.3 ;; leaf-alice 0.7.5 ;; leaf-bob ^3 ;; ;; intermediate-b-1.2.3 ;; leaf-bob 3.0.1 ;; ;; intermediate-c-1.0.1 ;; leaf-alice 0.7.5 (dev-dependency) ;; ;; leaf-alice-0.7.3 ;; leaf-alice-0.7.5 ;; ;; leaf-bob-3.0.1 ;; leaf-bob-3.0.2 (yanked) ;; leaf-bob-4.0.0 (yanked) (define test-foo-crate "{ \
index 16cd6e20d8..88864dc277 100644
--- a/
gnu/packages/ssh.scm
+++ b/
gnu/packages/ssh.scm
@@ -143,6 +143,7 @@ a server that supports the SSH-2 protocol.")
("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
+ #:configure-flags '("--sysconfdir=/etc")
#:phases
(modify-phases %standard-phases
(add-after 'configure 'reset-/var/empty