aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 490062c134..92ee0cfbeb 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1124,30 +1124,32 @@ include:
(define-public kopeninghours
(package
(name "kopeninghours")
- (version "23.04.3")
+ (version "24.05.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/"
version "/src/" name "-" version ".tar.xz"))
(sha256
(base32
- "14m4wl79b4qad42l1capz59pslfcrm25jshyhmcqzhqb0wzwkav9"))))
+ "132ihgsv1l8nz24ycddfp146czhnfcgrjfnffjb91w5l4a5wv3k4"))))
(build-system cmake-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "ctest" "-E"
- "(evaluatetest|iterationtest)")))))))
+ (list
+ #:configure-flags #~(list "-DBUILD_WITH_QT6=ON")
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (invoke "ctest" "-E"
+ "(evaluatetest|iterationtest)")))))))
(native-inputs (list bison extra-cmake-modules flex))
(inputs (list boost
kholidays
ki18n
osmctools
- qtbase-5
- qtdeclarative-5))
+ qtbase
+ qtdeclarative))
(home-page "https://invent.kde.org/libraries/kopeninghours")
(synopsis "Get opening hours from OpenStreetMap")
(description