aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-typeguard-python3.10.patch47
-rw-r--r--gnu/packages/python-xyz.scm3
2 files changed, 49 insertions, 1 deletions
diff --git a/gnu/packages/patches/python-typeguard-python3.10.patch b/gnu/packages/patches/python-typeguard-python3.10.patch
new file mode 100644
index 0000000000..29321d8918
--- /dev/null
+++ b/gnu/packages/patches/python-typeguard-python3.10.patch
@@ -0,0 +1,47 @@
+Taken from Gentoo, which adapted
+https://github.com/agronholm/typeguard/commit/e0db07a777d5a481eaba6162354adf32286ce21b
+
+diff --git a/src/typeguard/__init__.py b/src/typeguard/__init__.py
+index 5684d63..27fa30b 100644
+--- a/src/typeguard/__init__.py
++++ b/src/typeguard/__init__.py
+@@ -61,22 +61,25 @@ except ImportError:
+ from typing import _ForwardRef as ForwardRef
+ evaluate_forwardref = ForwardRef._eval_type
+
+-if sys.version_info >= (3, 10):
+- from typing import is_typeddict
+-else:
+- _typed_dict_meta_types = ()
+- if sys.version_info >= (3, 8):
+- from typing import _TypedDictMeta
+- _typed_dict_meta_types += (_TypedDictMeta,)
++try:
++ from typing_extensions import is_typeddict
++except ImportError:
++ if sys.version_info >= (3, 10):
++ from typing import is_typeddict
++ else:
++ _typed_dict_meta_types = ()
++ if sys.version_info >= (3, 8):
++ from typing import _TypedDictMeta
++ _typed_dict_meta_types += (_TypedDictMeta,)
+
+- try:
+- from typing_extensions import _TypedDictMeta
+- _typed_dict_meta_types += (_TypedDictMeta,)
+- except ImportError:
+- pass
++ try:
++ from typing_extensions import _TypedDictMeta
++ _typed_dict_meta_types += (_TypedDictMeta,)
++ except ImportError:
++ pass
+
+- def is_typeddict(tp) -> bool:
+- return isinstance(tp, _typed_dict_meta_types)
++ def is_typeddict(tp) -> bool:
++ return isinstance(tp, _typed_dict_meta_types)
+
+
+ if TYPE_CHECKING:
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d637b073df..d1908ec956 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22390,7 +22390,8 @@ based on the CPython 2.7 and 3.7 parsers.")
(method url-fetch)
(uri (pypi-uri "typeguard" version))
(sha256
- (base32 "1i5qzcyw2715h1g1hvj7fxykck2bkxyshpngjr3nfcx1lf6smv80"))))
+ (base32 "1i5qzcyw2715h1g1hvj7fxykck2bkxyshpngjr3nfcx1lf6smv80"))
+ (patches (search-patches "python-typeguard-python3.10.patch"))))
(build-system python-build-system)
(arguments
(list