aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dns.scm6
-rw-r--r--gnu/packages/patches/knot-remove-runtime-deps.patch19
2 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index ba611ada2b..e911a142ef 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -845,7 +845,7 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "3.3.8")
+ (version "3.4.1")
(source
(origin
(method git-fetch)
@@ -854,7 +854,9 @@ Extensions} (DNSSEC).")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0iaardlmvcp6f0vccs81f202bb53y7fkcw5n12ahgqymqzhafpmq"))
+ (base32 "0iqzqfjk60lxzbjgkjsf1l8vqnv6rgz1z0p1zyhdqnp037123d4j"))
+ (patches
+ (search-patches "knot-remove-runtime-deps.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/knot-remove-runtime-deps.patch b/gnu/packages/patches/knot-remove-runtime-deps.patch
new file mode 100644
index 0000000000..8c5cf21d46
--- /dev/null
+++ b/gnu/packages/patches/knot-remove-runtime-deps.patch
@@ -0,0 +1,19 @@
+Following patch is imported from nixpkgs:
+
+source: https://github.com/NixOS/nixpkgs/pull/338995
+
+Remove unnecessary runtime dependencies.
+
+`knotc status configure` shows summary from the configure script,
+but that contains also references like include paths.
+Filter these at least in a crude way (whole lines).
+--- a/configure.ac
++++ b/configure.ac
+@@ -788,5 +788,5 @@ result_msg_base="
+-result_msg_esc=$(echo -n " Configure:$filtered_config_params\n$result_msg_base" | sed '$!s/$/\\n/' | tr -d '\n')
++result_msg_esc=$(echo -n " Configure:$filtered_config_params\n$result_msg_base" | grep -Fv "$NIX_STORE" | sed '$!s/$/\\n/' | tr -d '\n')
+
+ AC_DEFINE_UNQUOTED([CONFIGURE_SUMMARY],["$result_msg_esc"],[Configure summary])
+
+
+