aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index a72f491fd0..4fd5f8fa00 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -678,6 +678,17 @@ library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
(base32
"0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compilation
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("find_package.PkgConfig" all)
+ (string-append
+ "set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
+ all))))))))
(native-inputs (list gcc-13 pkg-config))
(inputs (list hyprutils))
(home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")