aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 30775c7fa4..4d2b68e1c6 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1398,6 +1398,30 @@ performance critical code.")
utilities for Julia.")
(license license:expat)))
+(define-public julia-pdmats
+ (package
+ (name "julia-pdmats")
+ (version "0.11.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaStats/PDMats.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gyhfjmb0qlqgx2398b356cph25bnpjagcslckv41bzyf8pg3ybl"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaStats/PDMats.jl")
+ (synopsis
+ "Uniform Interface for positive definite matrices of various structures")
+ (description "PDMats.jl supports efficient computation on positive definite
+matrices of various structures. In particular, it provides uniform interfaces
+to use positive definite matrices of various structures for writing generic
+algorithms, while ensuring that the most efficient implementation is used in
+actual computation.")
+ (license license:expat)))
+
(define-public julia-reexport
(package
(name "julia-reexport")
le-system, check-f2fs-file-system) (check-ntfs-file-system, check-file-system): Take and honour new FORCE? and REPAIR arguments. Update the docstring. Adjust all callers. * gnu/system/file-systems.scm <file-system>: Add new SKIP-CHECK-IF-CLEAN? and REPAIR fields. (file-system->spec, spec->file-system): Adjust accordingly. * gnu/build/linux-boot.scm (mount-root-file-system): Take new SKIP-CHECK-IF-CLEAN? and REPAIR keyword arguments. Thread them through to CHECK-FILE-SYSTEM. * doc/guix.texi (File Systems): Document both new <file-system> options. Tobias Geerinckx-Rice 2021-09-12linux-boot: Remove mummified comment....* gnu/build/linux-boot.scm (configure-qemu-networking): Delete 2014 comment about not doing something here. Tobias Geerinckx-Rice 2021-06-16gnu: Respect ‘rootdelay’ kernel command-line argument....* gnu/build/linux-boot.scm (boot-system): Sleep for "rootdelay=SECONDS" when specified on the kernel command line. Tobias Geerinckx-Rice 2021-05-23gnu: Respect the root file-system's CHECK? field....* gnu/build/linux-boot.scm (mount-root-file-system): Take a new #:CHECK? keyword argument. Add it to the docstring. Conditionally call CHECK-FILE-SYSTEM. (boot-system): Adjust its only caller to pass the <file-system>'s CHECK? option through, if available. Tobias Geerinckx-Rice 2020-12-17linux-boot: Fix noresume argument parsing....* gnu/build/linux-boot.scm (boot-system): Check for "hibernate=noresume" in addition to "noresume". Tobias Geerinckx-Rice 2020-11-07linux-boot: Resume from hibernation....* gnu/build/linux-boot.scm (resume-if-hibernated): New procedure. (boot-system): Call it. Tobias Geerinckx-Rice 2020-09-07linux-boot: Handle nfs-root device strings....* gnu/build/linux-boot.scm (device-string->file-system-device): Support nfs-root "device" strings. * gnu/build/file-systems.scm (canonicalize-device-spec): Support nfs-root "device" strings. * gnu/machine/ssh.scm (machine-check-file-system-availability): Avoid checking of NFS file systems. * gnu/system.scm (read-boot-parameters, device-sexp->device): Support nfs-root "device" strings. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Stefan