aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
'1'>ssdiff
context:2020-08-25offload: Modify the build-machine record to accept multiple systems....* guix/scripts/offload.scm (<build-machine>)[systems]: New field. [system]: Accessor changed to %build-machine-system. Default to #f. * guix/scripts/offload.scm (build-machine-system): Wrap %build-machine-system with a deprecation warning. (build-machine-systems): Access the new systems field or fallback to use build-machine-system, for backward compatibility. (machine-matches?): Adjust. * tests/offload.scm: Add tests... * Makefile.am (SCM_TESTS): ...and register them. * doc/guix.texi (Daemon Offload Setup): Update doc. Maxim Cournoyer
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/code.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index b9267b0f21..df830d55a1 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -181,7 +181,7 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(wrap-program
(string-append (assoc-ref outputs "out")
"/share/gtags/script/pygments_parser.py")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))))
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
;; Install the plugin files in the right place.