aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-build.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index c5438b5e78..61e035d384 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -179,34 +179,23 @@ Python file, so it can be easily copied into your project.")
(define-public python-tomli
(package
(name "python-tomli")
- (version "2.0.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tomli" version))
(sha256
- (base32 "1q8lrh9ypa6zpgbc5f7z23p7phzblp4vpxdrpfr1wajhb17w74n2"))))
- (build-system python-build-system)
+ (base32 "0kwazq3i18rphcr8gak4fgzdcj5w5bbn4k4j2l6ma32gj496qlny"))))
+ (build-system pyproject-build-system)
(arguments
`(#:tests? #f ;disabled to avoid extra dependencies
#:phases
(modify-phases %standard-phases
- (replace 'build
+ (add-before 'build 'add-self-to-path
(lambda _
- (setenv "PYTHONPATH" (string-append (getcwd) ":"
- (getenv "GUIX_PYTHONPATH")))
- (invoke "python" "-m" "build" "--wheel" "--no-isolation"
- "--skip-dependency-check")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" out whl)))))))
- (native-inputs
- `(("python-flit-core-bootstrap" ,python-flit-core-bootstrap)
- ("python-pypa-build" ,python-pypa-build)
- ("python-six", python-six-bootstrap)))
+ ;; The build system of tomli requires... tomli.
+ (setenv "PYTHONPATH" "src"))))))
+ (native-inputs (list python-flit-core-bootstrap python-six-bootstrap))
(home-page "https://github.com/hukkin/tomli")
(synopsis "Small and fast TOML parser")
(description "Tomli is a minimal TOML parser that is fully compatible with
filters: Update to 3.2.0.Julien Lepiller 2022-02-05gnu: java-jsr250: Use proper source.Julien Lepiller 2022-02-05gnu: java-plexus-sec-dispatcher: Update to 2.0.Julien Lepiller 2022-02-05gnu: Add java-plexus-build-api.Julien Lepiller 2022-02-05gnu: java-plexus-utils: Default to the newer one.Julien Lepiller 2022-01-12gnu: Add maven-resolver-transport-http.Reily Siegel 2022-01-12gnu: Add maven-resolver-transport-file.Reily Siegel 2021-12-30gnu: Remove trailing period from synopsis.Vagrant Cascadian 2021-12-13gnu: Simplify package inputs.Ludovic Courtès 2021-06-22gnu: maven-enforcer-parent-pom: Fix pom.Julien Lepiller 2021-06-22gnu: maven-core: Hardcode versions we have in Guix.Julien Lepiller 2021-06-22guix: java-utils: Factorize pom.xml generation.Julien Lepiller