aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 619d2edafb..07df78ce6b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -414,6 +414,26 @@ opportunities to Perl developers as GNU Autoconf does for Shell developers.")
CPAN::Meta object are present.")
(license (package-license perl))))
+(define-public perl-data-dump
+ (package
+ (name "perl-data-dump")
+ (version "1.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GA/GAAS/"
+ "Data-Dump-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ciqlwsy1q35s94dry9bjy1pwanbq6b7q4rhxm9z8prgkzbslg2k"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Data-Dump")
+ (synopsis "Pretty printing of data structures")
+ (description "This module provide functions that takes a list of values as
+their argument and produces a string as its result. The string contains Perl
+code that, when \"eval\"ed, produces a deep copy of the original arguments.")
+ (license (package-license perl))))
+
(define-public perl-data-optlist
(package
(name "perl-data-optlist")
changing permissions of the parent....Ludovic Courtès 2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès 2020-06-10database: separate transaction-handling and retry-handling....Caleb Ristvedt 2020-06-10database: ensure update-or-insert is run within a transaction...Caleb Ristvedt 2020-06-10database: rewrite query procedures in terms of with-statement....Caleb Ristvedt 2020-06-06ui: 'display-search-results' automatically invokes the pager....Ludovic Courtès 2020-06-05git-authenticate: Add tests....Ludovic Courtès 2020-05-16gexp: Add 'let-system'....Ludovic Courtès 2020-03-22store: Add 'with-build-handler'....Ludovic Courtès 2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès 2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès 2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès 2019-09-23git: Add 'commit-difference'....Ludovic Courtès 2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès 2019-05-27publish: Add support for lzip....Ludovic Courtès 2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt 2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès