aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/benchmark.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 9b06cc4d58..5bd16ad7be 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -46,14 +46,14 @@
(define-public fio
(package
(name "fio")
- (version "3.20")
+ (version "3.21")
(source (origin
(method url-fetch)
(uri (string-append "https://brick.kernel.dk/snaps/"
"fio-" version ".tar.bz2"))
(sha256
(base32
- "1mwqafn81a9pxy2kw9rl4p3r2brhg2ckwrcwzy0q4gffxgn3k9c7"))))
+ "0np1scxqfpd6fcnnnfyn8xdsh6lc5pyq3vk1jm1zk7sa58fvccd4"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
se-module (guix gexp) #:use-module (guix packages) #:use-module (guix build-system trivial) #:export (make-icecat-extension)) (define* (make-icecat-extension pkg #:optional (pkg-output "out")) "Create an Icecat extension from package PKG and return a package that, when installed, will make the extension contained in PKG available as an Icecat browser extension. PKG-OUTPUT specifies which output of PKG to use." (package (inherit pkg) (location (package-location pkg)) (name (string-append (package-name pkg) "-icecat")) (native-inputs '()) (inputs '()) (propagated-inputs (package-propagated-inputs pkg)) (outputs '("out")) (build-system trivial-build-system) (arguments (list #:modules '((guix build utils)) #:builder #~(begin (use-modules (guix build utils)) (let* ((addon-id #$(assq-ref (package-properties pkg) 'addon-id)) (moz-app-id "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}") (search-dir (string-append #$output "/lib/icecat/extensions/" moz-app-id))) ;; Icecat's iterates over `search-dir` for directories. If a ;; directory's name is not a valid add-on ID, it is ignored. See ;; `DirectoryLocation::readAddons()` in XPIProvider.jsm. ;; This directory has to be a symlink, because Icecat's ;; `_readLinkFile(aFile)` calls `normalize()` only if `aFile` is a ;; symlink. ;; Normalizing is required because Icecat compares the add-on path ;; against its local database to know if there is an extension ;; update. We want the add-on path to be the package store path, ;; so that a path change is detected every time the package is ;; updated. See `updateExistingAddon()` in XPIDatabase.jsm, with ;; our patch `icecat-compare-paths.patch`. ;; We don't want the add-on path to be the profile store path, ;; which would change too often. We don't want the add-on path to ;; be hard-coded either because it would never change (but it ;; wouldn't make sense anyway). (mkdir-p search-dir) (symlink (in-vicinity (ungexp pkg pkg-output) addon-id) (in-vicinity search-dir addon-id))))))))