aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7fb8da9641..b96daad0ff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3698,27 +3698,28 @@ engine.")
"1n1lsh96vnyc1pnzyd30f9prcsclmvmkdb3nm5aahnyizyiy6lar"))))
(build-system ruby-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-unnecessary-dependencies
- (lambda _
- ;; pry is a debugging tool, and is unnecessary when running the
- ;; tests
- (substitute* "spec/lib/hamster/vector/insert_spec.rb"
- (("require 'pry'") ""))
- (substitute* "spec/spec_helper.rb"
- (("require \"pry\"") "")
- ;; CodeClimate is an online service, and is unnecessary for
- ;; running the tests
- (("require \"codeclimate-test-reporter\"") "")
- (("CodeClimate.*\n") ""))
- #t))
- ;; No Rakefile is included, so run rspec directly.
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "rspec"))
- #t)))))
+ (list
+ ;; Only supports Ruby 2 currently
+ #:ruby ruby-2.7
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-unnecessary-dependencies
+ (lambda _
+ ;; pry is a debugging tool, and is unnecessary when running the
+ ;; tests
+ (substitute* "spec/lib/hamster/vector/insert_spec.rb"
+ (("require 'pry'") ""))
+ (substitute* "spec/spec_helper.rb"
+ (("require \"pry\"") "")
+ ;; CodeClimate is an online service, and is unnecessary for
+ ;; running the tests
+ (("require \"codeclimate-test-reporter\"") "")
+ (("CodeClimate.*\n") ""))))
+ ;; No Rakefile is included, so run rspec directly.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ruby" (which "rspec"))))))))
(propagated-inputs
(list ruby-concurrent))
(native-inputs