aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cf172ab58a..53d3e28d27 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -812,3 +812,24 @@ automatically detected. Colors and highlighting can be combined and nested.
New styles can also be created easily. This package was inspired by the
\"chalk\" JavaScript project.")
(license license:expat)))
+
+(define-public r-testthat
+ (package
+ (name "r-testthat")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "testthat" version))
+ (sha256
+ (base32
+ "0b3akwcx5mv9dmi8vssbk91hr3yrrdxd2fm6zhr31fnyz8kjx4pw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-crayon" ,r-crayon)))
+ (home-page "https://github.com/hadley/testthat")
+ (synopsis "Unit testing for R")
+ (description
+ "This package provides a unit testing system for R designed to be fun,
+flexible and easy to set up.")
+ (license license:expat)))
/tr> 2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....Tobias Geerinckx-Rice 2017-02-17gnu: %static-inputs: Use 'grep' without custom phase....Efraim Flashner 2017-01-06Merge branch 'master' into core-updatesLeo Famulari 2017-01-04gnu: gcc: Adjust for PowerPC....Carlos Sánchez de La Lama 2017-01-03gnu: Use hurd-triplet? to check if GNU/Hurd....Manolis Ragkousis 2016-12-07gnu: make-bootstrap: Produce the correct %glibc-bootstrap-tarball for Hurd sy......Manolis Ragkousis 2016-11-06Merge branch 'master' into core-updatesMark H Weaver 2016-11-04gnu: Remove '%final-inputs' references at the top level....Ludovic Courtès 2016-10-23Merge branch 'master' into core-updatesMark H Weaver 2016-10-19gnu: %static-inputs: Use bash from PATH in bootstrap tar....Carlos Sánchez de La Lama 2016-10-13gnu: guile: Graft 2.0.13....Ludovic Courtès 2016-10-13gnu: make-bootstrap: Remove duplicate definition of 'bash-static'....Ludovic Courtès 2016-05-10gnu: glibc: Rename linux-headers input to kernel-headers....Manolis Ragkousis 2016-04-27gnu: Add missing synopses and descriptions....Ludovic Courtès 2015-09-13Merge branch 'master' into core-updatesLudovic Courtès 2015-09-06gnu: Set license of the bootstrap tools....Ludovic Courtès 2015-09-06gnu: bash-light: Rename to bash-minimal....Alex Kost 2015-09-04gnu: make-bootstrap: Remove unneeded configure flag from %gcc-static....Manolis Ragkousis 2015-09-03Build tarballs with deterministic file ordering....Mark H Weaver 2015-08-29gnu: Use 'install-file' instead of 'mkdir-p' and 'copy-file' in obvious cases....Ludovic Courtès