path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e282a6f24e..f4b074dbab 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1346,13 +1346,13 @@ disable tests, have before and after blocks that run once and more.")
(define-public ruby-connection-pool
(package
(name "ruby-connection-pool")
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (rubygems-uri "connection_pool" version))
(sha256
(base32
- "17vpaj6kyf2i8bimaxz7rg1kyadf4d10642ja67qiqlhwgczl2w7"))))
+ "0lflx29mlznf1hn0nihkgllzbj8xp5qasn8j7h838465pi399k68"))))
(build-system ruby-build-system)
(native-inputs
`(("bundler" ,bundler)))
on information.") (license license:bsd-2)))) (define-public sbsigntools (package (name "sbsigntools") (version "0.9.5") (source (origin (method git-fetch) (uri (git-reference (url "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git") (commit (string-append "v" version)) (recursive? #t))) (file-name (git-file-name name version)) (sha256 (base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4")))) (build-system gnu-build-system) (arguments (list #:phases #~(modify-phases %standard-phases (add-after 'unpack 'patch-more-shebangs (lambda* (#:key inputs native-inputs #:allow-other-keys) (substitute* "lib/ccan.git/tools/create-ccan-tree" (("#!/bin/bash") (string-append "#!" (search-input-file (or native-inputs inputs) "/bin/bash")))))) (add-after 'unpack 'patch (lambda _ (substitute* '("configure.ac" "tests/Makefile.am") (("/usr/include/efi") (string-append #$(this-package-input "gnu-efi") "/include/efi")) (("/usr/lib/gnuefi") (string-append #$(this-package-input "gnu-efi") "/lib"))))) (add-after 'unpack 'setenv (lambda _ (setenv "CC" #$(cc-for-target))))))) (native-inputs (list autoconf automake bash help2man pkg-config util-linux)) ; getopt (inputs (list gnu-efi `(,util-linux "lib") ; libuuid openssl)) (synopsis "EFI signing tools") (description "This package provides tools for signing EFI binaries.") (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/") (license license:gpl3+))) (define-public efitools (package (name "efitools") (version "1.9.2") (source (origin (method git-fetch) (uri (git-reference (url "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0jabgl2pxvfl780yvghq131ylpf82k7banjz0ksjhlm66ik8gb1i")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; No tests exist. #:make-flags '("CC=gcc") #:phases (modify-phases %standard-phases (add-after 'unpack 'patch (lambda* (#:key inputs outputs #:allow-other-keys) (substitute* "Make.rules" (("/usr/include/efi") (string-append (assoc-ref inputs "gnu-efi") "/include/efi")) (("\\$\\(DESTDIR\\)/usr") (string-append (assoc-ref outputs "out"))) (("/usr/lib/gnuefi") (string-append (assoc-ref inputs "gnu-efi") "/lib"))) #t)) (add-after 'unpack 'patch-more-shebangs (lambda* (#:key inputs #:allow-other-keys) (substitute* "xxdi.pl" (("#!.*") (string-append "#!" (assoc-ref inputs "perl") "/bin/perl\n"))) #t)) (delete 'configure)))) (native-inputs (list help2man perl perl-file-slurp sbsigntools)) (inputs (list gnu-efi openssl)) (synopsis "EFI tools (key management, variable management)") (description "This package provides EFI tools for EFI key management and EFI variable management.") (home-page "https://blog.hansenpartnership.com/efitools-1-4-with-linux-key-manipulation-utilities-released/") ;; Programs are under GPL 2. ;; Library routines (in lib/) are under LGPL 2.1. ;; Compiling/linking/using OpenSSL is permitted. (license (list license:gpl2 license:lgpl2.1)))) (define-public efilinux (package (name "efilinux") (version "1.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/mfleming/efilinux") (commit (string-append "efilinux-" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0b4nxzr3wl5v4b52r79iw1arfgasz26xb38r2blw9v2qz2s1q9w2")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" ,@(match (%current-system) ("aarch64-linux" '("ARCH=aarch64")) ("armhf-linux" '("ARCH=arm")) (_ '())) (string-append "INCDIR=" (assoc-ref %build-inputs "gnu-efi") "/include") (string-append "LIBDIR=" (assoc-ref %build-inputs "gnu-efi") "/lib")) #:tests? #f ; No tests exist. #:phases (modify-phases %standard-phases (delete 'configure) (replace 'install (lambda* (#:key outputs #:allow-other-keys) (install-file "efilinux.efi" (string-append (assoc-ref outputs "out") "/libexec")) #t))))) (inputs (list gnu-efi)) (synopsis "Minimal Linux loader for UEFI") (description "This package provides a minimal Linux loader as an UEFI program.") (home-page "https://github.com/mfleming/efilinux") (license license:bsd-2)))