aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/documentation.scm3
-rw-r--r--gnu/packages/patches/python-docrepr-fix-tests.patch16
2 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index bbaa01e392..be64bc4f95 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -296,7 +296,8 @@ objects.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ma5gwy93m1djd3zdlnqfrwhgr8ic1qbsz5kkrb9f987ax40lfkd"))))
+ "1ma5gwy93m1djd3zdlnqfrwhgr8ic1qbsz5kkrb9f987ax40lfkd"))
+ (patches (search-patches "python-docrepr-fix-tests.patch"))))
(build-system python-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/python-docrepr-fix-tests.patch b/gnu/packages/patches/python-docrepr-fix-tests.patch
new file mode 100644
index 0000000000..a209921025
--- /dev/null
+++ b/gnu/packages/patches/python-docrepr-fix-tests.patch
@@ -0,0 +1,16 @@
+Fixes the errors with use of asyncio in docrepr/tests/test_output.py:
+
+> await compare_screenshots(test_id, url)
+E TypeError: 'coroutine' object is not callable
+
+--- a/conftest.py
++++ b/conftest.py
+@@ -65,7 +65,7 @@ def _open_browser(url):
+
+
+ @pytest.fixture
+-async def compare_screenshots(request):
++def compare_screenshots(request):
+ """Run visual regression test on the output."""
+ async def _compare_screenshots(test_id, url):
+ if (request.config.getoption(COMPARE_SCREENSHOTS_OPTION) or