aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 58132b334a..c28d389f88 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3146,7 +3146,14 @@ libxml2 and libxslt.")
version ".tar.gz"))
(sha256
(base32
- "04aj80jhfbmxqzvmq40zfi4z3cw6vi01m3wkk6diz3lc971cfnw9"))))
+ "04aj80jhfbmxqzvmq40zfi4z3cw6vi01m3wkk6diz3lc971cfnw9"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Adapt to newer freetype. As the package is unmaintained upstream,
+ ;; there is no use in creating a patch and reporting it.
+ '(substitute* "_imagingft.c"
+ (("freetype/")
+ "freetype2/")))))
(build-system python-build-system)
(inputs
`(("freetype" ,freetype)