aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust-apps.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index e835426d80..5829fb6be3 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2590,6 +2590,14 @@ It will then write @code{fixup!} commits for each of those changes.")
(substitute-keyword-arguments (package-arguments rust-xremap)
((#:features _) '(list "wlroots"))))))
+(define-public xremap-x11
+ (package
+ (inherit rust-xremap)
+ (name "xremap-x11")
+ (arguments
+ (substitute-keyword-arguments (package-arguments rust-xremap)
+ ((#:features _) '(list "x11"))))))
+
(define-public xsv
(package
(name "xsv")
8.html. In a nutshell: the convention is to use special rules for special forms (macros), not for procedures. * .dir-locals.el (scheme-mode): Remove the special indentation rules for the computed-file and gexp->derivation procedures. Maxim Cournoyer 2023-03-05.dir-locals.el: Allow Guix root-dir overrides when working via Tramp....* .dir-localsl.el: Add only the local part of the root directory to the guile search path. This lets you use Tramp to hack on a remote Guix checkout. Signed-off-by: Leo Famulari <leo@famulari.name> Brian Cully 2023-02-19.dir-locals: Add let-keywords indentation rules....* .dir-locals.el (scheme-mode): Add let-keywords indentation rules. Maxim Cournoyer 2023-02-02.dir-locals.el: Adjust indentation rule for test-assertm....* .dir-locals.el: Adjust the scheme-indent-function property for test-assertm, so that the two first arguments (the test name and the store variable) are indented as procedure arguments. Maxim Cournoyer 2023-02-02.dir-locals.el: Add indentation rule for computed-file....* .dir-locals.el: Configure scheme-indent-function property for computed-file, so that its first argument (the file name) is indented as a procedure argument. Maxim Cournoyer 2022-09-07.dir-locals.el: Update yas snippets directory....* .dir-locals.el (eval): Update yas snippets directory. Andrew Tropin 2022-09-05.dir-locals.el: Add .go to completion-ignored-extensions....* .dir-locals.el (eval): Add .go to completion-ignored-extensions. Andrew Tropin 2022-09-05.dir-locals.el: Add guix yasnippets....* .dir-locals.el (eval): Add guix yasnippets. Andrew Tropin 2022-07-10monads: Add 'mparameterize'....* etc/system-tests.scm (mparameterize): Move to... * guix/monads.scm (mparameterize): ... here. * tests/monads.scm ("mparameterize"): New test. * .dir-locals.el (c-mode): Add it. Ludovic Courtès 2022-07-10.dir-locals.el: Restore Emacs 27 lisp-fill-paragraph behavior....* .dir-locals.el (scheme-mode): Set fill-paragraph-function to a lisp-fill-paragraph version that matches that of Emacs 27. Maxim Cournoyer 2022-06-28.dir-locals.el: Properly indent 'wrap-script'....* .dir-locals.el (scheme-mode): Indent 'wrap-script' the same way as 'wrap-program'. Maxim Cournoyer 2022-06-07.dir-locals: Adjust to bug-reference-mode in Emacs 28....* .dir-locals.el: Adjust 'bug-reference-bug-regexp' and 'bug-reference-url-format' to Emacs 28. Ludovic Courtès 2022-03-06import: github: Reuse HTTP connection for the /tags URL fallback....* guix/import/github.scm (fetch-releases-or-tags): Call 'open-connection-for-uri' and reuse the same connection for the two 'http-fetch' calls. * .dir-locals.el (scheme-mode): Add 'call-with-port'. Ludovic Courtès 2022-03-06tests: Add (guix http-client) tests....* tests/http-client.scm: New file. * Makefile.am (SCM_TESTS): Add it. * .dir-locals.el (scheme-mode): Add 'with-http-server'. Ludovic Courtès 2022-01-29.dir-locals.el: Don't mess up indentation of prepend and append....The current version appears to assume special values in the first and second package, but it's either all lists (default append) or all package input expressions (inside modify-inputs), which themselves are either packages or lists consisting of a package and a string. * .dir-locals.el: Drop (eval . (put 'prepend 'scheme-indent-function 2)) and (eval . (put 'append 'scheme-indent-function 2)). Liliana Marie Prikler