aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7790e78779..9aa61bd8f8 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -703,40 +703,41 @@ computing environments.")
(define-public python-scikit-learn
(package
(name "python-scikit-learn")
- (version "0.19.1")
+ (version "0.19.2")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/scikit-learn/scikit-learn/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scikit-learn/scikit-learn.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "18n8775kyfwbvcjjjzda9c5sqy4737c0hrmj6qj1ps2jmlqzair9"))
+ "1dk9hdj01c0bny4ps78b7869fjw9gr6qklxf6wyql8h6nh4k19xm"))
(patches (search-patches
- "python-scikit-learn-fix-test-non-determinism.patch"))))
+ "python-scikit-learn-fix-test-non-determinism.patch"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'check
- ;; Running tests from the source directory requires
- ;; an "inplace" build with paths relative to CWD.
- ;; http://scikit-learn.org/stable/developers/advanced_installation.html#testing
- ;; Use the installed version instead.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- ;; some tests require access to "$HOME"
- (setenv "HOME" "/tmp")
- ;; Step out of the source directory just to be sure.
- (chdir "..")
- (invoke "nosetests" "-v" "sklearn"))))))
+ (add-after 'build 'build-ext
+ (lambda _ (invoke "python" "setup.py" "build_ext" "--inplace") #t))
+ (replace 'check
+ (lambda _
+ ;; Restrict OpenBLAS threads to prevent segfaults while testing!
+ (setenv "OPENBLAS_NUM_THREADS" "1")
+ ;; Disable tests that require network access
+ (delete-file "sklearn/datasets/tests/test_mldata.py")
+ (delete-file "sklearn/datasets/tests/test_rcv1.py")
+ (invoke "pytest" "sklearn")
+ #t))
+ ;; FIXME: This fails with permission denied
+ (delete 'reset-gzip-timestamps))))
(inputs
`(("openblas" ,openblas)))
(native-inputs
- `(("python-nose" ,python-nose)
+ `(("python-pytest" ,python-pytest)
+ ("python-pandas" ,python-pandas) ;for tests
("python-cython" ,python-cython)))
(propagated-inputs
`(("python-numpy" ,python-numpy)
@@ -744,8 +745,8 @@ computing environments.")
(home-page "http://scikit-learn.org/")
(synopsis "Machine Learning in Python")
(description
- "Scikit-learn provides simple and efficient tools for data
-mining and data analysis.")
+ "Scikit-learn provides simple and efficient tools for data mining and
+data analysis.")
(license license:bsd-3)))
(define-public python2-scikit-learn
d23096f930be68efc691ccb793cc76f'>.guix-authorizations: Remove biscuolo due to inactivity....* .guix-authorizations: Remove biscuolo. Leo Famulari 2021-04-07.guix-authorizations: Remove wingo due to inactivity....* .guix-authorizations: Remove wingo. Leo Famulari 2021-04-07.guix-authorizations: Remove sleep_walker due to inactivity....* .guix-authorizations: Remove sleep_walker. Leo Famulari 2021-04-07.guix-authorizations: Remove rhelling due to inactivity....* .guix-authorizations: Remove rhelling. Leo Famulari 2021-04-07.guix-authorizations: Remove lsl88 due to inactivity....* .guix-authorizations: Remove lsl88. Leo Famulari 2021-04-07.guix-authorizations: Remove benwoodcroft due to inactivity....* .guix-authorizations: Remove benwoodcroft. Leo Famulari 2021-04-07.guix-authorizations: Remove alexvong1995 due to inactivity....* .guix-authorizations: Remove alexvong1995. Leo Famulari 2021-04-06.guix-authorizations: Remove taylanub....This is a followup to the events discussed here: https://lists.gnu.org/archive/html/guix-devel/2021-03/msg00195.html Taylan was already removed from the Guix project on Savannah on March 10, 2021. * .guix-authorizations: Remove taylanub from the committers. Leo Famulari 2021-04-06.guix-authorizations: Remove thomasd....* .guix-authorizations: Remove thomasd from the committers. Leo Famulari 2021-03-08.guix-authorizations: Add lbraun....* .guix-authorizations: Add lbraun and "lbraun (professional)" to the committers. Leo Famulari 2021-02-18.guix-authorizations: Add lle_bout....* .guix-authorizations: Add lle_bout to the committers. Tobias Geerinckx-Rice 2020-12-28.guix-authorizations: Add leoprikler....* .guix-authorizations: Add leoprikler to the committers. Ludovic Courtès 2020-11-15.guix-authorizations: Add jonsger....* .guix-authorizations: Add jonsger to the committers. Marius Bakke 2020-10-16.guix-authorizations: Add m1gu3l....* .guix-authorizations: Add m1gu3l to the committers. Ludovic Courtès 2020-09-04.guix-authorizations: Add planglois to the committers....* .guix-authorizations: Add planglois. Ludovic Courtès 2020-07-18.guix-authorizations: Add brettgilio (back) to the committers....* .guix-authorizations: Add fingerprint for brettgilio. Tobias Geerinckx-Rice 2020-07-01.guix-authorizations: Remove keys of two former contributors....* .guix-authorizations: Remove key of David Craven, who left the project in 2017, and Federico Beffa, whose last commit was in Feb. 2017. Ludovic Courtès 2020-07-01.guix-authorizations: Remove former keys that are no longer used....* .guix-authorizations: Remove old keys of dvc, efraim, and janneke. Ludovic Courtès 2020-07-01.guix-authorizations: Remove brettgilio's old key....* .guix-authorizations: Remove key "DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE" (Brett Gilio). See <https://lists.gnu.org/archive/html/guix-devel/2020-06/msg00323.html>. Ludovic Courtès 2020-05-04.guix-authorizations: Add bricewge to the committers....* .guix-authorizations: Add fingerprint for bricewge. Ludovic Courtès 2020-05-04.guix-authorizations: Augment....* .guix-authorizations: Add all the currently authorized committers. Ludovic Courtès 2020-05-04Add '.guix-authorizations'....* .guix-authorizations: New file. Ludovic Courtès