aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 34b2c694cd..040b1787b4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6747,6 +6747,25 @@ also provides V-style logging controlled by the @code{-v} and
@code{https://github.com/golang/glog}.")
(license license:asl2.0)))
+(define-public go-k8s-io-klog-v2
+ (package
+ (inherit go-k8s-io-klog)
+ (name "go-k8s-io-klog-v2")
+ (version "2.130.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kubernetes/klog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12q9jhxfpq75sgmdxgcz85znbgdi04ic9zy3rm0c47n24clz6z73"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "k8s.io/klog/v2"))))
+
(define-public go-mvdan-cc-editorconfig
(package
(name "go-mvdan-cc-editorconfig")
bb09291f04a84fa2'>daemon: Run 'guix authenticate' directly....Ludovic Courtès 2019-09-08daemon: Invoke 'guix gc --list-busy' instead of 'list-runtime-roots'....Ludovic Courtès 2019-02-04daemon: Add "/guix" to default 'nixLibexecDir'....Ludovic Courtès 2019-02-04daemon: Remove unused 'NIX_DATA_DIR' environment variable....Ludovic Courtès 2018-11-14daemon: Install 'authenticate' script under LIBEXECDIR/guix....Ludovic Courtès 2018-06-22build: Remove leftover reference to nix/libstore/schema.sql....Ludovic Courtès 2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès 2018-06-14database: 'with-database' can now initialize new databases....Ludovic Courtès 2018-06-08build: Do not add all of $(BUILT_SOURCES) to $(CLEANFILES)....Ludovic Courtès 2018-01-07daemon: Make libbz2 an optional dependency....Ludovic Courtès 2018-01-07daemon: Add gzip log compression....Ludovic Courtès 2017-03-06build: Don't embed absolute paths in .service and .conf service files....Leo Famulari 2016-12-20build: Delete all the .service and .conf files upon 'make clean'....Ludovic Courtès 2016-12-18build: Fix .service and .conf targets for VPATH builds....Ludovic Courtès 2016-12-18build: Add 'guix-publish.*.in' to the distribution....Ludovic Courtès 2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel 2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès 2016-10-28daemon: Factor out SQLite handling....Eelco Dolstra 2016-06-26daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'....David Craven 2016-05-31daemon: Remove unused XML output code....Ludovic Courtès 2016-05-24build: Use "%D%" in Makefile fragments....Mathieu Lirzin 2016-04-21build: Move 'Makefile' fragments to subdirectories....Mathieu Lirzin