aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b3a81092db..0d0ff58f1b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5554,6 +5554,25 @@ always (re)defines a command. There is also @code{\\makeenvironment} and
@code{\\provideenvironment} for environments.")
(license license:lppl1.3c+)))
+(define-public texlive-latex-marginfix
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-marginfix"
+ (list "doc/latex/marginfix/"
+ "tex/latex/marginfix/")
+ (base32 "1qinf42mjry8bi5h3kgbi6hcymnk8fw0w43527wm95nc365dq0mf")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/marginfix")
+ (synopsis "Patch \\marginpar to avoid overfull margins")
+ (description
+ "Authors using LaTeX to typeset books with significant margin material
+often run into the problem of long notes running off the bottom of the page.
+This package implements a solution to make marginpars ``just work'' by keeping
+a list of floating inserts and arranging them intelligently in the output
+routine.")
+ (license license:lppl)))
+
(define-public texlive-metalogo
(package
(inherit (simple-texlive-package
9:27 +0100'>2022-03-07derivations: Coalesce inputs that have the same output path....Fixes <https://issues.guix.gnu.org/54209>. * guix/derivations.scm (coalesce-duplicate-inputs): Use the output paths of DRV as a hash table key. * tests/derivations.scm ("derivation with duplicate fixed-output inputs"): Expect a single input for FINAL. ("derivation with equivalent fixed-output inputs"): New test. Ludovic Courtès 2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Files smaller than 8 KiB typically represent ~70% of the entries in /gnu/store/.links but only contribute to ~4% of the space savings afforded by deduplication. Not considering these files for deduplication speeds up file insertion in the store and, more importantly, leaves 'removeUnusedLinks' with fewer entries to traverse, thereby speeding it up proportionally. Partly fixes <https://issues.guix.gnu.org/24937>. * config-daemon.ac: Remove symlink hard link check and CAN_LINK_SYMLINK definition. * guix/store/deduplication.scm (%deduplication-minimum-size): New variable. (deduplicate)[loop]: Do not recurse when FILE's size is below %DEDUPLICATION-MINIMUM-SIZE. (dump-port): New procedure. (dump-file/deduplicate)[hash]: Turn into... [dump-and-compute-hash]: ... this thunk. Call 'deduplicate' only when SIZE is greater than %DEDUPLICATION-MINIMUM-SIZE; otherwise call 'dump-port'. * nix/libstore/gc.cc (LocalStore::removeUnusedLinks): Drop files where st.st_size < deduplicationMinSize. * nix/libstore/local-store.hh (deduplicationMinSize): New declaration. * nix/libstore/optimise-store.cc (deduplicationMinSize): New variable. (LocalStore::optimisePath_): Return when PATH is a symlink or smaller than 'deduplicationMinSize'. * tests/derivations.scm ("identical files are deduplicated"): Produce files bigger than %DEDUPLICATION-MINIMUM-SIZE. * tests/nar.scm ("restore-file-set with directories (signed, valid)"): Likewise. * tests/store-deduplication.scm ("deduplicate, below %deduplication-minimum-size"): New test. ("deduplicate", "deduplicate, ENOSPC"): Produce files bigger than %DEDUPLICATION-MINIMUM-SIZE. * tests/store.scm ("substitute, deduplication"): Likewise. Ludovic Courtès