aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index db35c2532c..6f449f0c39 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1286,8 +1286,8 @@ worksheet templates.")))
(define-public librseq
;; There's no release.
- (let ((commit "170f840b498e1aff068b90188727a656111bfc2f")
- (revision "1"))
+ (let ((commit "c3ed6b64bbe1944bd8de8b9fde14e7c290f02a90")
+ (revision "2"))
(package
(name "librseq")
(version (git-version "0.0.0" revision commit))
@@ -1299,9 +1299,15 @@ worksheet templates.")))
(file-name (git-file-name name version))
(sha256
(base32
- "0rdx59y8y9x8cfmmx5gl66gibkzpk3kw5lrrqhrxan8zr37a055y"))))
+ "046lrfw87gjbr4rvs054s6wk22c4xcmrcww04wkpnxmy5vp33mk3"))))
(build-system gnu-build-system)
- (native-inputs (list autoconf automake libtool))
+ (inputs
+ (list numactl))
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ pkg-config))
(home-page "https://github.com/compudj/librseq")
(synopsis "Userspace library for restartable sequences")
(description "A restartable sequence is a critical region delimited by a
linux-libre/6.11-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Co-authored-by: Ahmad Draidi <a.r.draidi@redscript.org> Change-Id: I35bad9fbea9f568e60e7f24c95f85c240ef96277 Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-08-26gnu: Remove linux-libre 6.9....* gnu/packages/linux.scm (linux-libre-6.9-version, linux-libre-6.9-gnu-revision, deblob-scripts-6.9, linux-libre-6.9-pristine-source, linux-libre-6.9-source, linux-libre-headers-6.9, linux-libre-6.9): Remove variables. (linux-libre-headers-latest): New variable. (libbpf)[native-inputs]: Switch to linux-libre-headers-latest. * gnu/packages/aux-files/linux-libre/6.9-arm.conf, gnu/packages/aux-files/linux-libre/6.9-arm64.conf, gnu/packages/aux-files/linux-libre/6.9-riscv.conf gnu/packages/aux-files/linux-libre/6.9-i686.conf, gnu/packages/aux-files/linux-libre/6.9-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Change-Id: Ia05bce46ab94f0dbbc7bb5b2e75e2067e9b78e7b Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-07-29gnu: Add linux-libre 6.10.1....* gnu/packages/linux.scm (linux-libre-6.10-version, linux-libre-6.10-gnu-revision, deblob-scripts-6.10, linux-libre-6.10-pristine-source, linux-libre-6.10-source, linux-libre-headers-6.10, linux-libre-6.10): New variables. * gnu/packages/aux-files/linux-libre/6.10-arm.conf, gnu/packages/aux-files/linux-libre/6.10-arm64.conf, gnu/packages/aux-files/linux-libre/6.10-i686.conf, gnu/packages/aux-files/linux-libre/6.10-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Change-Id: If62ec2e8029ebd7531d3b4ba9a666c0b5f3b0f4c Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-07-07gnu: emacs-next: Update to 30.0.60-1.4e22ef8....* gnu/packages/aux-files/emacs/comp-integrity-next.el: New file. * Makefile.am (AUX_FILES): Register it here. * gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.60-1.4e22ef8. (emacs->emacs-next)[arguments]: Swap out ‘validate-comp-integrity’ phase, so as to refer to the new integrity check. Liliana Marie Prikler 2024-06-17gnu: Remove linux-libre 6.8....* gnu/packages/linux.scm (linux-libre-6.8-version, linux-libre-6.8-gnu-revision, deblob-scripts-6.8, linux-libre-6.8-pristine-source, linux-libre-6.8-source, linux-libre-headers-6.8, linux-libre-6.8): Remove variables. * gnu/packages/aux-files/linux-libre/6.8-arm.conf, gnu/packages/aux-files/linux-libre/6.8-arm64.conf, gnu/packages/aux-files/linux-libre/6.8-riscv.conf gnu/packages/aux-files/linux-libre/6.8-i686.conf, gnu/packages/aux-files/linux-libre/6.8-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: Ib94c61f629721f94a307e51b449e5ccd117a2f9a Wilko Meyer 2024-06-06gnu: linux-libre: Add 6.9-riscv.conf...* gnu/packages/aux-files/linux-libre/6.9-riscv.conf: New file. * Makefile.am (AUX_FILES): Register it. Change-Id: I1f5e24726c3a59bec73805068548ce5916b427f8 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Zheng Junjie 2024-06-03build: Align the Automake status lines of the po4a and the PO xref....* Makefile.am (AM_V_PO4A_0, AM_V_POXREF_0): Align the Automake status lines of the po4a and the PO xref, since the common width is 10 characters. Change-Id: Ic8c32f73294ba6e4ca71ab4aa889a558e4d7fcee Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de> gemmaro 2024-05-26gnu: Add linux-libre 6.9....Big thanks to Dariqq <dariqq@posteo.net> for debugging and communicating upstream about a problem with the deblobbing scripts in this kernel series! * gnu/packages/linux.scm (linux-libre-6.9-version, linux-libre-6.9-gnu-revision, deblob-scripts-6.9, linux-libre-6.9-pristine-source, linux-libre-6.9-source, linux-libre-headers-6.9, linux-libre-6.9): New variables. * gnu/packages/aux-files/linux-libre/6.9-arm.conf, gnu/packages/aux-files/linux-libre/6.9-arm64.conf, gnu/packages/aux-files/linux-libre/6.9-i686.conf, gnu/packages/aux-files/linux-libre/6.9-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I8dc011a603684f0be88766b7881aa6c560b94443 Wilko Meyer 2024-05-25maint: Suggest ‘guix git authenticate’ for initial authentication....The previous recommendation, running ‘make authenticate’, was insecure because it led users to run code from the very repository they want to authenticate: https://lists.gnu.org/archive/html/guix-devel/2024-04/msg00252.html * Makefile.am (commit_v1_0_0, channel_intro_commit) (channel_intro_signer, GUIX_GIT_KEYRING, authenticate): Remove. * Makefile.am (.git/hooks/%): New target, generalization of previous ‘.git/hooks/pre-push’ target. (nodist_noinst_DATA): Add ‘.git/hooks/post-merge’. * doc/contributing.texi (Building from Git): Suggest ‘guix git authenticate’ instead of ‘make authenticate’. * etc/git/post-merge: New file. * etc/git/pre-push: Run ‘guix git authenticate’ instead of ‘make authenticate’. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Reported-by: Skyler Ferris <skyvine@protonmail.com> Change-Id: Ia415aa8375013d0dd095e891116f6ce841d93efd Ludovic Courtès 2024-05-22gnu: linux-libre-6.8: Add riscv config....* gnu/packages/aux-files/linux-libre/6.8-riscv.conf: New files. * Makefile.am (AUX_FILES): Add it. Change-Id: I293912d4f7fe09e281432b0f973999d9d8db582a Zheng Junjie 2024-05-19import: Add binary npm importer....* guix/scripts/import.scm: (importers): Add "npm-binary". * doc/guix.texi (Invoking guix import): Document npm-binary importer. * guix/import/npm-binary.scm: New file. * guix/scripts/import/npm-binary.scm: New file. * tests/npm-binary.scm: New file. * Makefile.am: Add them. Co-authored-by: Timothy Sample <samplet@ngyro.com> Co-authored-by: Lars-Dominik Braun <lars@6xq.net> Change-Id: I98a45068cf5b9c42790664cc743feaa7ac76f807 Jelle Licht