aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm35
-rw-r--r--gnu/packages/patches/modglue-fix-build.patch17
2 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f2f595a3a3..c464351fc1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -4812,6 +4812,41 @@ server for Python and pypy3.")
(home-page "https://freeopcua.github.io/")
(license license:lgpl3+)))
+(define-public modglue
+ (package
+ (name "modglue")
+ (version "1.20")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kpeeters/modglue.git")
+ (commit "89d65f5be9c737123b7beb721bd96c4eed650d9a")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cfrp2wyyfb6c71s5skg2g7gdg7bpvv77x6rvw7r9dqvamxsgmih"))
+ (patches
+ (search-patches "modglue-fix-build.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:make-flags
+ (list "TIMESTAMP=-DDATETIME=\\\"\\\" -DHOSTNAME=\\\"\\\"")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "-C" "src" "tests"))))))
+ (native-inputs
+ (list pkg-config libtool))
+ (inputs
+ (list libsigc++-2))
+ (synopsis "C++ library for handling of multiple co-processes")
+ (description "This package provides a C++ library for handling of
+multiple co-processes in cadabra.")
+ (home-page "https://cadabra.science/")
+ (license license:gpl2+)))
+
(define-public cadabra2
(package
(name "cadabra2")
diff --git a/gnu/packages/patches/modglue-fix-build.patch b/gnu/packages/patches/modglue-fix-build.patch
new file mode 100644
index 0000000000..76b533b75f
--- /dev/null
+++ b/gnu/packages/patches/modglue-fix-build.patch
@@ -0,0 +1,17 @@
+Author: Danny Milosavljevic <dannym+c@friendly-machines.com>
+Date: 23 Dec 2024
+License: GPL2+
+
+diff -ru orig/l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc
+--- orig/l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc 2024-12-23 20:23:47.132475052 +0100
++++ l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc 2024-12-23 20:24:08.028172621 +0100
+@@ -241,8 +241,8 @@
+ struct iovec iov[1];
+ struct msghdr msg;
+ struct {
+- struct cmsghdr cm;
+ int fd;
++ struct cmsghdr cm;
+ } cmsg;
+
+ memset( &msg, 0, sizeof(msg) );