aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/time.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 9b006a5438..746ba97c0f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2017, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
@@ -418,7 +418,10 @@ timestamps.")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "pytest" "-vv" "tests"))))))
+ (invoke "pytest" "-vv" "tests"
+ ;; python-dateutil doesn't recognize America/Nuuk.
+ ;; Remove when python-dateutil > 2.8.1.
+ "-k" "not test_parse_tz_name_zzz"))))))
(native-inputs
`(;; For testing
("python-chai" ,python-chai)
ref='/guix/commit/gnu/services/docker.scm?id=a9a67da573222715ea3152eacdfb5d3840dccd9a'>services: docker: Disable configuration serialization....* gnu/services/docker.scm (serialize-boolean): Delete procedure. (docker-configuration) <no-serialization>: New syntactic keyword. Maxim Cournoyer 2020-10-17services: docker: Fix missing containerd-shim binary....This commit fixes error 'time="2020-10-16T…" level=error msg="Handler for POST /v1.40/containers/…/start returned error: failed to start shim: exec: \"containerd-shim\": executable file not found in $PATH: unknown"'. * gnu/services/docker.scm (containerd-shepherd-service): Add "containerd-shim" to PATH. Oleg Pykhalov 2020-09-23services: docker: Fix configuration....This is a follow-up to e04b90607ac903359c90c9bad1b67fb7ce2f0eb6. * gnu/services/docker.scm (docker-shepherd-service): Fix "enable-proxy?" configuration. Oleg Pykhalov 2020-09-21services: Docker: Fix typo in configuration....This is a follow-up to f0a09310e6ff2ed63770cb585c551ba94ce4a9d0. * gnu/services/docker.scm (docker-shepherd-service): Properly reference variables in service definition. Efraim Flashner 2020-09-21services: docker: Fix enable-proxy? option....The userland proxy option does not properly disable the userland proxy when set to false. Docker defaults to enabling the userland proxy if the option is unset on the command line. * gnu/services/docker.scm (docker-shepherd-service): Properly handle the 'enable-proxy?' option. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jesse Dowell 2020-09-15services: docker: Fix service definition....This commit follows a404716d411cf7cd49ff02e3100f0bbf6622d6d5. * gnu/services/docker.scm (docker-configuration)[docker-cli]: New record field. (docker-service-type): Use this. * doc/guix.texi (Miscellaneous Services)[Docker Service]: Document this. Oleg Pykhalov 2020-09-14services: docker: Fix service definition....This is a follow-up to 8422a67dc16af4dd5eb82180463aa7a0b362d5b9. * gnu/services/docker.scm (docker-service-type): Use a composed list for packages in profile-service-type. Efraim Flashner 2020-09-14services: docker: Make docker command available....* gnu/services/docker.scm (docker-service-type): Extend the profile-service-type and add the docker-cli package. Efraim Flashner