aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9e2419abe0..fe0af87b51 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -421,16 +421,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.9)))
-(define-public linux-libre-4.4-version "4.4.256")
+(define-public linux-libre-4.4-version "4.4.257")
(define deblob-scripts-4.4
(linux-libre-deblob-scripts
- ;; See the comment in deblob-scripts-4.9
- "4.4.255"
+ linux-libre-4.4-version
(base32 "0x2j1i88am54ih2mk7gyl79g25l9zz4r08xhl482l3fvjj2irwbw")
(base32 "0hhin1jpfkd6nwrb6xqxjzl3hdxy4pn8a15hy2d3d83yw6pflbsf")))
(define-public linux-libre-4.4-pristine-source
(let ((version linux-libre-4.4-version)
- (hash (base32 "1z7vfy4h0mjvv0rcvvpb55x5fl16c6cgpcafz5gpjp0pw1p2lva8")))
+ (hash (base32 "0njb4gf77vix2xgnyhmrzf67czpqfng9np644l9j18dn4mb7q1iy")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.4)))
td>gnu: Add elm-random....* gnu/packages/elm.scm (elm-random): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-debois-elm-dom....* gnu/packages/elm.scm (elm-debois-elm-dom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-todomvc....* gnu/packages/elm.scm (elm-todomvc): New variable. * doc/guix.texi (Build Systems)[elm-build-system]: Mention it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: elm: Support 'elm reactor'....* gnu/packages/elm.scm (elm): Rename to ... (elm-sans-reactor): ... this new variable. [synopsis, description]: Tweak. (elm): New variable. * guix/build-system/elm.scm (default-elm): Use elm-sans-reactor. * doc/guix.texi (Build Systems)[elm-build-system]: Update accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-explorations-markdown....* gnu/packages/elm.scm (elm-explorations-markdown): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-project-metadata-utils....* gnu/packages/elm.scm (elm-project-metadata-utils): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-parser....* gnu/packages/elm.scm (elm-parser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-http....* gnu/packages/elm.scm (elm-http): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-file....* gnu/packages/elm.scm (elm-file): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-bytes....* gnu/packages/elm.scm (elm-bytes): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-browser....* gnu/packages/elm.scm (elm-browser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-url....* gnu/packages/elm.scm (elm-url): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-time....* gnu/packages/elm.scm (elm-time): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-svg....* gnu/packages/elm.scm (elm-svg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-html....* gnu/packages/elm.scm (elm-html): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-virtual-dom....* gnu/packages/elm.scm (elm-virtual-dom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: Add elm-core and elm-json....Both of these packages are needed for 'elm-build-system' to work. * gnu/packages/elm.scm (elm-core, elm-json, elm-json-bootstrap): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22guix: Add elm-build-system....* gnu/packages/patches/elm-offline-package-registry.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/elm.scm (elm): Use it. * guix/build-system/elm.scm, guix/build/elm-build-system.scm, tests/elm.scm: New files. * Makefile.scm (MODULES, SCM_TESTS): Add them. * doc/guix.texi (Build Systems): Document 'elm-build-system'. * doc/contributing.texi (Elm Packages): New section. Document naming conventions and utilities. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: elm: Rename package to match the command....* gnu/packages/elm.scm (elm-compiler): Rename to ... (elm): ... this variable, leaving 'elm-compiler' as a deprecated alias. [description]: Tweak. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath 2022-05-22gnu: elm-compiler: Update to 0.19.1....* gnu/packages/patches/elm-compiler-disable-reactor.patch, gnu/packages/patches/elm-compiler-fix-map-key.patch: Delete files. * gnu/packages/patches/elm-reactor-static-files.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/elm.scm (elm-compiler): Update to 0.19.1. [origin]<patches>: Remove stale patches. Add new patch. [arguments]: Use G-expressions. Add #:configure-flags for new patch. [inputs]: Remove ghc-file-embed. Add ghc-filelock. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Philip McGrath