aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b553d4534a..3463ac85a7 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6378,6 +6378,15 @@ output.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
+ ;; name.
+ (substitute* '("Keyboard/ckbcomp")
+ (("\"cat ")
+ (string-append "\"" (which "cat")
+ " ")))
+ #t))
(add-before 'build 'make-doubled-bdfs
(lambda* (#:key inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"
ix/commit/gnu/tests/install.scm?id=3fbf38aca2af5613755bad62a21edd60e251852a'>tests: Pass '-F qcow2' to 'qemu-img create'....Ludovic Courtès 2021-09-23tests: install: Test an XFS root file system....Tobias Geerinckx-Rice 2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer 2021-08-29gnu: bootloader: Support multiple targets....Maxim Cournoyer 2021-07-04installer: tests: Expect but do not select other services by default....Tobias Geerinckx-Rice 2021-04-28tests: Add gui-uefi-installed-os test....Mathieu Othacehe 2021-01-27system: tests: Add a Btrfs RAID system test....Maxim Cournoyer 2021-01-20tests: install: Fix build....Mathieu Othacehe 2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas 2020-11-26mapped-devices: Add 'lvm-device-mapping'....Mikhail Tsykalov 2020-10-30installer: Use UUIDs in the 'swap-devices' field....Ludovic Courtès 2020-10-13installer: Add Emacs EXWM desktop environment....Jan (janneke) Nieuwenhuizen 2020-09-30system: image: Add image-type support....Mathieu Othacehe