aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm132
1 files changed, 78 insertions, 54 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a44a871ba2..e90689384f 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2014, 2015, 2024 宋文武 <iyzsong@envs.net>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
@@ -134,7 +134,7 @@ Xfce Desktop Environment.")
(define-public xfconf
(package
(name "xfconf")
- (version "4.18.1")
+ (version "4.18.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -142,7 +142,7 @@ Xfce Desktop Environment.")
"xfconf-" version ".tar.bz2"))
(sha256
(base32
- "0mr20250mp4pgy82v5kvb0hp5060vy6yz9hd6icmmp6gpd8lfwfr"))))
+ "165xbr6y5z4zr235znkqlwkcy2ib9hgfqrdic0n7p57nas8ccv65"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -332,7 +332,7 @@ development.")
(define-public garcon
(package
(name "garcon")
- (version "4.18.1")
+ (version "4.18.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -340,7 +340,7 @@ development.")
"garcon-" version ".tar.bz2"))
(sha256
(base32
- "02y2nkxwx5mp1w6x2ydi3hpgymk7159zvyzk70afp5dcdlm96ypy"))))
+ "0ka35nxqhl4cbmyf9x2ysinihixsqmibqywqr2zqz5iiw699530v"))))
(build-system gnu-build-system)
(native-inputs
(list `(,glib "bin") gobject-introspection intltool pkg-config))
@@ -359,7 +359,7 @@ merging features essential for loading menus modified with menu editors.")
(define-public tumbler
(package
(name "tumbler")
- (version "4.18.1")
+ (version "4.18.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -367,7 +367,7 @@ merging features essential for loading menus modified with menu editors.")
"tumbler-" version ".tar.bz2"))
(sha256
(base32
- "1833qnfw2c9wv7iw5cad5x5scj1rsqmmbwfld33zxx8akhd9hqgz"))))
+ "0ymy6a0hbv5iainphgpd7dfi8snpg7zs7lyqq2cgiiza6p3fwc5m"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config intltool
@@ -398,7 +398,7 @@ management D-Bus specification.")
(define-public xfce4-panel
(package
(name "xfce4-panel")
- (version "4.18.4")
+ (version "4.18.6")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -406,7 +406,7 @@ management D-Bus specification.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0m7vmk7rc2sjfqba0flgnw77kn1j222xqs7r86bpg8sf1614yc1j"))
+ "0qkw1msrvq7hc4mjg9iai0kymgkrpj1nijv04zjbdfcbymhp2cr1"))
(patches (search-patches "xfce4-panel-plugins.patch"))))
(build-system gnu-build-system)
(arguments
@@ -471,7 +471,7 @@ applications menu, workspace switcher and more.")
(define-public xfce4-clipman-plugin
(package
(name "xfce4-clipman-plugin")
- (version "1.6.4")
+ (version "1.6.6")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -479,7 +479,7 @@ applications menu, workspace switcher and more.")
"xfce4-clipman-plugin-" version ".tar.bz2"))
(sha256
(base32
- "1v5c1z154a46426198m3pl0fyrlsgfiqy4x9rvzcwzlp6lg5iplz"))))
+ "083i9pbcqjkdzzjx055ld4gd4gn3xnc3rn10vpsqv1vg01dlgb88"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
@@ -498,7 +498,7 @@ matching them against regular expressions.")
(define-public xfce4-pulseaudio-plugin
(package
(name "xfce4-pulseaudio-plugin")
- (version "0.4.7")
+ (version "0.4.8")
(source
(origin
(method url-fetch)
@@ -507,7 +507,7 @@ matching them against regular expressions.")
(version-major+minor version) "/"
"xfce4-pulseaudio-plugin-" version ".tar.bz2"))
(sha256
- (base32 "0b4fjvrrah0b97cbv8ds7r6cwnj392ya2r7703ixf724f43hkpah"))))
+ (base32 "0j037wnx0z22nw11mq0y3cnq1srr52zckjap3klj3hirghh2nx5x"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config dbus-glib dbus))
@@ -605,7 +605,7 @@ per window.")
(define-public xfce4-appfinder
(package
(name "xfce4-appfinder")
- (version "4.18.0")
+ (version "4.18.1")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -614,7 +614,7 @@ per window.")
"/" name "-" version ".tar.bz2"))
(sha256
(base32
- "136137w2xc78jq0xcbymjwdxapllwyy7h3ydshz0gli7ngbrhaln"))))
+ "1yck11y86d45yxsppd1yqk894k3cf5vh91a5sm559gl175jylm4q"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config intltool))
@@ -682,7 +682,7 @@ allows you to shut down the computer from Xfce.")
(define-public xfce4-settings
(package
(name "xfce4-settings")
- (version "4.18.3")
+ (version "4.18.4")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -690,7 +690,7 @@ allows you to shut down the computer from Xfce.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "18giyc190i7b3nc3l745p6fqpnqivwxm0yc7l0whfa03wndykf9d"))
+ "1p513i8zwc3glv2cf3x2abwm4hvdb7clamj19yadj2036v85a37i"))
(patches (search-patches "xfce4-settings-defaults.patch"))))
(build-system gnu-build-system)
(arguments
@@ -727,7 +727,7 @@ like appearance, display, keyboard and mouse settings.")
(define-public thunar
(package
(name "thunar")
- (version "4.18.7") ;stable version = even minor
+ (version "4.18.10") ;stable version = even minor
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -735,7 +735,7 @@ like appearance, display, keyboard and mouse settings.")
"thunar-" version ".tar.bz2"))
(sha256
(base32
- "0shbbih2l6h3sda2221h7gsskv2lnchnmypk76cdgf51iafafxi2"))))
+ "020xrwzdnk5b7cli8vmv3yn7sfq6pg7bz57m4p0xh0ln2cgqlc78"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-custom-thunarx-dirs-enabled")))
@@ -793,7 +793,7 @@ and import the new pictures from your camera.")
(define-public thunar-archive-plugin
(package
(name "thunar-archive-plugin")
- (version "0.5.1")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
@@ -801,7 +801,7 @@ and import the new pictures from your camera.")
name "/" (version-major+minor version)
"/" name "-" version ".tar.bz2"))
(sha256
- (base32 "1vcbbmh2vw43231c7vbkwc35pmhj7ixb65fvssrwfxydsfqkl6x8"))))
+ (base32 "1qxdsnwjy8z358yd0avi1h2r6y1izfv26dzlp5fsh3pwpivzhyb3"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config intltool))
(inputs (list exo thunar gtk+))
@@ -836,7 +836,7 @@ Samba from Thunar (the Xfce file manager) without requiring root access.")
(define-public thunar-media-tags-plugin
(package
(name "thunar-media-tags-plugin")
- (version "0.3.0")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
@@ -844,7 +844,7 @@ Samba from Thunar (the Xfce file manager) without requiring root access.")
name "/" (version-major+minor version)
"/" name "-" version ".tar.bz2"))
(sha256
- (base32 "06sr7b4p9f585gian8vpx7j0pkzg0vvwcrjmrhvh7i5sb90w8rg2"))))
+ (base32 "02n99ymqs8msa798r63sy409pwrycg8p4pxx3yf497k924g134lm"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config intltool))
(inputs (list exo gtk+ thunar taglib))
@@ -949,6 +949,26 @@ menu.")
on the screen.")
(license gpl2+)))
+(define-public xfwm4-themes
+ (package
+ (name "xfwm4-themes")
+ (version "4.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/art/xfwm4-themes/"
+ (version-major+minor version) "/"
+ "xfwm4-themes-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0xfmdykav4rf6gdxbd6fhmrfrvbdc1yjihz7r7lba0wp1vqda51j"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.xfce.org/")
+ (synopsis "Themes for the Xfce window manager")
+ (description "This package provides a set of additional themes for the Xfce
+window manager.")
+ (license gpl3+)))
+
(define-public xfdesktop
(package
(name "xfdesktop")
@@ -1012,7 +1032,7 @@ devices and folders.")
(define-public gigolo
(package
(name "gigolo")
- (version "0.5.2")
+ (version "0.5.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1020,7 +1040,7 @@ devices and folders.")
"/" name "-" version ".tar.bz2"))
(sha256
(base32
- "1hxv3lla567nnqxxly8xfi8fzmpcdhxb493x9hinr7szfnh1ljp3"))))
+ "1l1g9ljvyzir1jpjf0248nnwwf3sakwljlik6cj5wrj4azv88nfj"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config intltool))
(inputs (list gtk+))
@@ -1082,7 +1102,7 @@ features playback of local media files, DVD/CD and live streams.")
(define-public xfce4-terminal
(package
(name "xfce4-terminal")
- (version "1.1.0")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/" name "/"
@@ -1090,7 +1110,7 @@ features playback of local media files, DVD/CD and live streams.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "18yl792x617qa90g6caw4cy1arfl847majjxkxs0k6rb4ivk70j0"))))
+ "0i9xgd0rgw0j59hlp9kyxndw2b35nhxjls09c20rzdj1sj4dak91"))))
(build-system gnu-build-system)
(arguments
(list
@@ -1116,7 +1136,7 @@ on your desktop.")
(define-public xfce4-dict
(package
(name "xfce4-dict")
- (version "0.8.5")
+ (version "0.8.6")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/" name "/"
@@ -1124,7 +1144,7 @@ on your desktop.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "06xa7987azyx6y4mkmg58qv7gsg66szmr8ly29l9l1v1xl5sp7i9"))))
+ "0h8adjgb7126hafik7r1k9wr3g6d835ggsh8zj9k4k9mf35bfpdf"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
@@ -1226,6 +1246,7 @@ for and start applications.")
xfconf
xfdesktop
xfwm4
+ xfwm4-themes
xkill
;; Panel plugins.
xfce4-battery-plugin
@@ -1250,7 +1271,7 @@ system resources, while still being visually appealing and user friendly.")
(define-public xfce4-power-manager
(package
(name "xfce4-power-manager")
- (version "4.18.2")
+ (version "4.18.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -1258,7 +1279,7 @@ system resources, while still being visually appealing and user friendly.")
"xfce4-power-manager-" version ".tar.bz2"))
(sha256
(base32
- "0kfzvhb1hnr16fcplm7bdpp4fcxr3irzq3w4q0lpbc5n6kaqyq71"))))
+ "1w445v3911cf7l6w5c0f84aphv8s579f8srnhjrhf3drd07xsy8d"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config intltool))
@@ -1279,7 +1300,7 @@ inhibit interface which allows applications to prevent automatic sleep.")
(define-public ristretto
(package
(name "ristretto")
- (version "0.13.1")
+ (version "0.13.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/ristretto/"
@@ -1287,7 +1308,7 @@ inhibit interface which allows applications to prevent automatic sleep.")
"ristretto-" version ".tar.bz2"))
(sha256
(base32
- "07kraf6k18f53vgx98hvrb20hcm5134m7c958w96fl142nzzy6np"))))
+ "1nbxfm6ljcw45vn8hhjxwcv3k387hdah4jnn07n9w08n63g5x7vp"))))
(build-system gnu-build-system)
(native-inputs
(list intltool desktop-file-utils
@@ -1307,7 +1328,7 @@ the desktop wallpaper.")
(define-public xfce4-taskmanager
(package
(name "xfce4-taskmanager")
- (version "1.5.5")
+ (version "1.5.7")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1315,7 +1336,7 @@ the desktop wallpaper.")
"xfce4-taskmanager-" version ".tar.bz2"))
(sha256
(base32
- "1rcaalqv6sdsnc6ick8fifgkqcf2xiflw9yk5szqn2qs4jx02kzn"))))
+ "1fv83xcbnlwabi32z3fsdik1knh7v45ji529dx9kwlv4b8pq6dk7"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
@@ -1367,7 +1388,7 @@ several different time zones.")
(define-public xfce4-notifyd
(package
(name "xfce4-notifyd")
- (version "0.8.2")
+ (version "0.9.4")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1375,7 +1396,7 @@ several different time zones.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "115fy87lcn9scwx52kjs0g250q2d3r10sahl6l8l38fs13dqm8p3"))))
+ "063qxbcy8djijsb0clzkai3mwg43mmlswwrg403vsi2w0n614v5f"))))
(build-system glib-or-gtk-build-system)
(arguments
(list #:phases
@@ -1388,7 +1409,9 @@ several different time zones.")
(("\\$PKG_CONFIG --variable=glib_compile_resources gio-2.0")
"which glib-compile-resources")
(("\\$PKG_CONFIG --variable=glib_genmarshal glib-2.0")
- "which glib-genmarshal")))))))
+ "which glib-genmarshal")
+ (("\\$PKG_CONFIG --variable=glib_mkenums glib-2.0")
+ "which glib-mkenums")))))))
(native-inputs
(list intltool pkg-config (list glib "bin") which))
(inputs
@@ -1442,7 +1465,7 @@ of data to either CD/DVD/BD.")
(define-public mousepad
(package
(name "mousepad")
- (version "0.6.1")
+ (version "0.6.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/mousepad/"
@@ -1450,7 +1473,7 @@ of data to either CD/DVD/BD.")
version ".tar.bz2"))
(sha256
(base32
- "0dpzzy03hlw6gljp7ywdi6np41r88p2nr7rypwzy6zdwqwv5832n"))))
+ "17fi33mkdz1nfmsgqlfa20l06wwy0s8lcj21cfg6ikdiihxwpjp7"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '(;; Use the GSettings keyfile backend rather than
@@ -1481,7 +1504,7 @@ of data to either CD/DVD/BD.")
(define-public xfce4-screenshooter
(package
(name "xfce4-screenshooter")
- (version "1.10.4")
+ (version "1.10.5")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1491,7 +1514,7 @@ of data to either CD/DVD/BD.")
version ".tar.bz2"))
(sha256
(base32
- "1534h1a3a8b9pl20zpccaifrlsrbsihdcdjndn9nmqalgrl9kwd2"))))
+ "0732f1v6s1zkflq47rgdsimq73k7q94gwag1y9sza5smd8m1ywgs"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config intltool
@@ -1510,7 +1533,7 @@ A plugin for the Xfce panel is also available.")
(define-public xfce4-screensaver
(package
(name "xfce4-screensaver")
- (version "4.18.2")
+ (version "4.18.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1520,7 +1543,7 @@ A plugin for the Xfce panel is also available.")
version ".tar.bz2"))
(sha256
(base32
- "161bdsvkbknaf9fpz4b1r4amnm72hzfmx9c6krg2396k2k2d5z74"))))
+ "0f9sw703pcgz47689qgc550h2hpqlzvsfgggd7z9s6516rhk2wfi"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1581,7 +1604,7 @@ A plugin for the Xfce panel is also available.")
(define-public xfce4-cpugraph-plugin
(package
(name "xfce4-cpugraph-plugin")
- (version "1.2.8")
+ (version "1.2.10")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1590,7 +1613,7 @@ A plugin for the Xfce panel is also available.")
"/xfce4-cpugraph-plugin-" version ".tar.bz2"))
(sha256
(base32
- "1gylfmpn36cm1b1kz0x8smy5hixzlhmdg5i53cj5fzgk4773id5z"))))
+ "05frfn3y009xndks9rsw90jgk0v5zfarn5jqaqci45v9ab82sy9p"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
@@ -1766,7 +1789,7 @@ be clicked to open the chosen mount point.")
(define-public xfce4-genmon-plugin
(package
(name "xfce4-genmon-plugin")
- (version "4.1.1")
+ (version "4.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1775,7 +1798,7 @@ be clicked to open the chosen mount point.")
"/xfce4-genmon-plugin-" version ".tar.bz2"))
(sha256
(base32
- "0d81npcqnmkw2qaqa8c6igh9j5r4ivgb15zcjwxjkyhrzz89y4dj"))))
+ "0qh3b818kbf5sc07dshkd54nhqncsk0inlwv21zq8h11bzp0i3cl"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
@@ -2174,7 +2197,7 @@ lan interface (signal state, signal quality, network name (SSID)).")
(define-public xfce4-weather-plugin
(package
(name "xfce4-weather-plugin")
- (version "0.11.1")
+ (version "0.11.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -2183,12 +2206,12 @@ lan interface (signal state, signal quality, network name (SSID)).")
"/xfce4-weather-plugin-" version ".tar.bz2"))
(sha256
(base32
- "0fajhibacccfw0rl8741iz7qkqls4ynn9760j78rbp6wl3wlcld4"))))
+ "0sw7p8xsgyc7b5w92abigqz9mii79w2vdlprm5c0hmb3g3zhmm35"))))
(build-system gnu-build-system)
(native-inputs
(list intltool pkg-config))
(inputs
- (list gtk+ libsoup-minimal-2 libxfce4ui libxml2 xfce4-panel))
+ (list gtk+ json-c libsoup-minimal-2 libxfce4ui libxml2 xfce4-panel))
(home-page
"https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin")
(synopsis "Show information about local weather in the Xfce panel")
@@ -2200,7 +2223,7 @@ local weather in the panel, using forecast data provided by the
(define-public xfce4-dev-tools
(package
(name "xfce4-dev-tools")
- (version "4.18.0")
+ (version "4.18.1")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -2208,10 +2231,11 @@ local weather in the panel, using forecast data provided by the
"xfce4-dev-tools-" version ".tar.bz2"))
(sha256
(base32
- "0dxyfsx70nddkkv0ygkl02wv4p99g62zjkw68sf4bqzhap4lznzf"))))
+ "10bnb8q7sj60ahzfwrb3av4ngr17wk1p6jsnfv0yn8l90kksnb41"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ libxslt))
(inputs
(list glib))
(home-page "https://docs.xfce.org/xfce/xfce4-dev-tools/")