aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index fe12768159..7cacdd5f06 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1107,6 +1107,11 @@ asynchronous adapters (including tmux, screen, and a headless mode), and when
the job completes, errors will be loaded and parsed automatically.")
(license license:vim))))
+(define-public neovim-dispatch
+ (package
+ (inherit vim-dispatch)
+ (name "neovim-dispatch")))
+
(define-public vim-gemini-vim
;; No releases have been tagged.
(let ((commit "f300c54174fc0db8fb68f1bc04307b58612e9630")
dth: 28.6%;'/>
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 55f45d3c45..f81658d8de 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -271,11 +271,14 @@ This package includes the @command{tree-sitter} command-line tool.")
(grammar-directories '("."))
(article "a")
(inputs '())
+ (get-cleanup-snippet tree-sitter-delete-generated-files)
(license license:expat))
"Returns a package for Tree-sitter grammar. NAME will be used with
tree-sitter- prefix to generate package name and also for generating
REPOSITORY-URL value if it's not specified explicitly, TEXT is a string which
-will be used in description and synopsis."
+will be used in description and synopsis. GET-CLEANUP-SNIPPET is a function,
+it recieves GRAMMAR-DIRECTORIES as an argument and should return a G-exp,
+which will be used as a snippet in origin."
(let* ((multiple? (> (length grammar-directories) 1))
(grammar-names (string-append text " grammar" (if multiple? "s" "")))
(synopsis (string-append "Tree-sitter " grammar-names))
@@ -296,7 +299,7 @@ will be used in description and synopsis."
(file-name (git-file-name name version))
(sha256 (base32 hash))
(snippet
- (tree-sitter-delete-generated-files grammar-directories))))
+ (get-cleanup-snippet grammar-directories))))
(build-system tree-sitter-build-system)
(arguments (list #:grammar-directories grammar-directories))
(inputs inputs)