aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tree-sitter.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tree-sitter.scm')
-rw-r--r--gnu/packages/tree-sitter.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 22bf419a71..f7e35a062c 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -398,6 +398,13 @@ will be used in description and synopsis."
#:article "an"
#:repository-url "https://github.com/elm-tooling/tree-sitter-elm"))
+(define-public tree-sitter-gomod
+ (tree-sitter-grammar
+ "gomod" "Go .mod"
+ "1hblbi2bs4hlil703myqhvvq2y1x41rc3w903hg2bhbazh7x8yyf"
+ "1.0.0"
+ #:repository-url "https://github.com/camdencheek/tree-sitter-go-mod.git"))
+
(define-public tree-sitter-go
;; There are a lot of additions, the last tag was placed more than 1 year ago
(let ((commit "64457ea6b73ef5422ed1687178d4545c3e91334a")