aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/toolkits.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/toolkits.scm')
-rw-r--r--gnu/packages/toolkits.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 82b9490e62..a29ab01154 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -89,32 +89,33 @@
;; fontconfig.
(find-files "misc" "\\.cpp$"))))
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (header? (cut string-suffix? ".h" <>))
+ (lambda _
+ (let* ((header? (cut string-suffix? ".h" <>))
(imgui-headers (scandir "." header?))
(backend-headers (find-files
"backends"
"(glfw|opengl|sdl|vulkan).*\\.h$"))
(misc-headers (find-files "misc" "\\.h$")))
- (install-file "libimgui.so" (string-append out "/lib"))
+ (install-file "libimgui.so" (string-append #$output "/lib"))
;; Install headers.
(for-each (lambda (f)
- (install-file f (string-append out "/include/imgui")))
+ (install-file f (string-append #$output
+ "/include/imgui")))
imgui-headers)
(for-each (lambda (f)
(install-file f (string-append
- out "/include/imgui/backends")))
+ #$output
+ "/include/imgui/backends")))
backend-headers)
(for-each (lambda (f)
- (install-file f (string-append
- out "/include/imgui/" (dirname f))))
+ (install-file f (string-append #$output
+ "/include/imgui/"
+ (dirname f))))
misc-headers)
;; Install examples.
- (copy-recursively
- "examples" (string-append
- doc "/share/imgui/examples"))))))))
+ (copy-recursively "examples"
+ (string-append #$output:doc
+ "/share/imgui/examples"))))))))
(inputs (list fontconfig glfw mesa sdl2))
(home-page "https://github.com/ocornut/imgui")
(synopsis "Immediate-mode C++ GUI library with minimal dependencies")
roducibly....* doc/local.mk ($(srcdir)/doc/stamp-vti): New rule (overriding one provided by Automake). Co-authored-by: Janneke Nieuwenhuizen <janneke@gnu.org> Change-Id: If44965e9a3ecfb45865c58ee7a558951be8d15ae Timothy Sample 2024-04-03maint: Fix help2man for guix subcommands with `make V=2'....* doc/local.mk ($(srcdir)/%D%/guix-%.1): Use AM_V_HELP2MAN and cater for make's `@' silencing at the start of the command. Change-Id: Id80c48f0d7697167fea64700a7fe140003732d28 Janneke Nieuwenhuizen 2024-04-01nls: Update translations....* po/guix/ar.po: New file. * po/guix/LINGUAS: Add 'ar'. * po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add 'pt_BR' cookbook. * doc/local.mk: Add 'pt_BR' cookbook. * doc/htmlxref.cnf: Update URLs for cookbook. * doc/build.scm (%cookbook-languages): Add 'ko', 'pt_BR'. * doc/guix-cookbook.texi (Top): Mention 'ko', 'pt_BR' cookbook. Change-Id: Id1846ca100263b3fc1fa2ed52654c670270ee809 Florian Pelz 2023-08-29doc: Fix a potential problem in man page generation rule....Since commit ca8acad3 ("build: Add dependency on guix script for help2man targets."), the $< special Make variable in the recipe was matching scripts/guix instead of the more specific 'guix/scripts/%.scm' source. * doc/local.mk ($(srcdir)/%D%/guix-%.1): Move the scripts/guix prerequisite to the end. Maxim Cournoyer