aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm56
1 files changed, 25 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0f0399e868..300f525407 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4727,39 +4727,33 @@ loading fonts by their proper names instead of file names.")
(define-deprecated-package texlive-luatex-luaotfload texlive-luaotfload)
(define-public texlive-amsmath
- (let ((template (simple-texlive-package
- "texlive-amsmath"
- (list "/doc/latex/amsmath/"
- "/source/latex/amsmath/"
- ;; These two files are not generated from any of the
- ;; dtx/ins files.
- "/tex/latex/amsmath/amsmath-2018-12-01.sty"
- "/tex/latex/amsmath/amstex.sty")
- (base32
- "0gmdzhgr0h57xhsl61c5jsp4fj4pbmdr8p6k96am5jbyrbbx121q"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t)
- "latex/amsmath")))
- (propagated-inputs
- (list texlive-amsfonts))
- (home-page "https://www.ctan.org/pkg/amsmath")
- (synopsis "AMS mathematical facilities for LaTeX")
- (description
- "This is the principal package in the AMS-LaTeX distribution. It adapts
+ (package
+ (name "texlive-amsmath")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/amsmath/" "source/latex/amsmath/"
+ "tex/latex/amsmath/")
+ (base32
+ "0kqrgc1kbrgkw9kflazi5imdj8r2fbj2q44x6may362a6izzk2jq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-amsfonts))
+ (home-page "https://www.ctan.org/pkg/amsmath")
+ (synopsis "AMS mathematical facilities for LaTeX")
+ (description
+ "This is the principal package in the AMS-LaTeX distribution. It adapts
for use in LaTeX most of the mathematical features found in AMS-TeX; it is
highly recommended as an adjunct to serious mathematical typesetting in LaTeX.
-When amsmath is loaded, AMS-LaTeX packages @code{amsbsyamsbsy} (for bold
-symbols), @code{amsopnamsopn} (for operator names) and
-@code{amstextamstext} (for text embedded in mathematics) are also loaded.
-This package is part of the LaTeX required distribution; however, several
-contributed packages add still further to its appeal; examples are
-@code{empheqempheq}, which provides functions for decorating and highlighting
-mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
-definitions.")
- (license license:lppl1.3c+))))
+When amsmath is loaded, AMS-LaTeX packages @code{amsbsy} (for bold symbols),
+@code{amsopn} (for operator names) and @code{amstext} (for text embedded in
+mathematics) are also loaded. This package is part of the LaTeX required
+distribution; however, several contributed packages add still further to its
+appeal; examples are @code{empheq}, which provides functions for decorating
+and highlighting mathematics, and @code{ntheorem}, for specifying theorem (and
+similar) definitions.")
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-amsmath texlive-amsmath)