aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 16 insertions, 28 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5849f4f8d8..cd8d0d218c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5905,46 +5905,34 @@ headings.")
(define-deprecated-package texlive-latex-fncychap texlive-fncychap)
-(define-public texlive-latex-framed
+(define-public texlive-framed
(package
- (name "texlive-latex-framed")
+ (name "texlive-framed")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/framed"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "14a4ydqsvp3vcfavl21jrv0ybiqypaaqzg2q2cs3rzkandg7w98x"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/framed")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/framed")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/framed/"
+ "tex/latex/framed/")
+ (base32
+ "09hlzjlhz3q3l62h6gj997pfx1hc4726frhcdc6y5g66c3gh621g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/framed")
(synopsis "Framed or shaded regions that can break across pages")
(description
"The package creates three environments: @code{framed}, which puts an
ordinary frame box around the region, @code{shaded}, which shades the region,
and @code{leftbar}, which places a line at the left side. The environments
-allow a break at their start (the @code{\\FrameCommand} enables creation of a
-title that is “attached” to the environment); breaks are also allowed in the
+allow a break at their start (the @code{\\FrameCommand} enables creation of
+a title that is “attached” to the environment); breaks are also allowed in the
course of the framed/shaded matter. There is also a command
@code{\\MakeFramed} to make your own framed-style environments.")
;; The header states: "These macros may be freely transmitted, reproduced,
;; or modified for any purpose provided that this notice is left intact."
(license (license:fsf-free "file://framed.sty"))))
+(define-deprecated-package texlive-latex-framed texlive-framed)
+
(define-public texlive-latex-g-brief
(package
(name "texlive-latex-g-brief")
@@ -10686,7 +10674,7 @@ configuration of its own fixed names, using @file{.mld} files.")
texlive-etoolbox
texlive-fancyvrb
texlive-latex-float
- texlive-latex-framed
+ texlive-framed
texlive-fvextra
texlive-ifplatform
texlive-lineno