aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 76b3f91e4e..4e317f7517 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2587,20 +2587,14 @@ Meier, Nelson Aalen and regression.")
(define-public python-mapie
(package
(name "python-mapie")
- (version "0.8.6")
+ (version "0.9.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "MAPIE" version))
(sha256
(base32
- "013ljcjjl3k9yb3166fnvr6nsb9ph4rhidpdjjks78qw0w1j7faa"))))
+ "1lyqszfgmqfsyvfaxplzz84iqm7s49rdscjjhnxlymrasrizfp26"))))
(build-system pyproject-build-system)
- ;; See https://github.com/scikit-learn-contrib/MAPIE/issues/432
- (arguments
- (list
- #:test-flags
- '(list "-k" (string-append "not test_correct_results"
- " and not test_correct_results_binary"))))
(native-inputs (list python-pandas python-pytest python-setuptools
python-wheel))
(propagated-inputs (list python-numpy python-scikit-learn))
2024-11-12gnu: Add vdrift-data.Maxim Cournoyer * gnu/packages/games.scm (vdrift-data): New variable. Change-Id: I960e2222ea7e9506a306692db552dc1dcc229b01 2024-11-10gnu: ultrastar-deluxe: Update to 2024.10.0.Lars-Dominik Braun * gnu/packages/games.scm (ultrastar-deluxe): Bump version. [inputs]: Use ffmpeg 6 and ttf output of font-google-noto. Change-Id: I105c352abd8296a73dde54fecdfc6de7692e712e 2024-11-06gnu: Rename knights with knightsgame.Sughosha via Guix-patches via Rename knights with knightsgame to package knights from KDE games module. * gnu/packages/games.scm (knights): Rename with knightsgame. Change-Id: I6eec8189fd29fe2ede67d98c26fdd9cafe4c2aef 2024-10-31gnu: odamex: Update to 10.6.0.David Pflug * gnu/packages/games.scm (odamex): Update to 10.6.0. Change-Id: Ifbad7399f3e43b8a05948d8f7b1b73ba9b30477b 2024-10-22gnu: joycond: Update to 0.1.0-2.5b590ec.Maxim Cournoyer * gnu/packages/games.scm (joycond): Update to 0.1.0-2.5b590ec. Change-Id: I86a258b6d2992e6b72b4bc4b33b4fdfb2c94e296 2024-10-22Revert "gnu: joycond: Update to 0.1.0-2.9d1f509."Maxim Cournoyer Attempt to resolve a new 100% CPU spike problem. This partially reverts commit ecda7d3ef7c1b31d34a4353a2fd637b9d48d75a4. Change-Id: I9f5e05ae926e49367b2a57dad8f5188ddf0ad604 2024-10-19gnu: cowsay: Update to 3.8.3.Artyom V. Poptsov * gnu/packages/games.scm (cowsay): Update to 3.8.3. Change-Id: If6cbf75bec4bf95611356ee54d88c53c1389cf6f 2024-10-19gnu: joycond: Patch /bin/setfacl in udev rules.Maxim Cournoyer * gnu/packages/games.scm (joycond) [phases]: Extend the 'fix-bin-location' phase. Change-Id: Ie41f822db023369d5d35f9a960a9dadf994663e8 2024-10-19gnu: joycond: Update to 0.1.0-2.9d1f509, use gexps and fix license.Maxim Cournoyer * gnu/packages/games.scm (joycond): Update to 0.1.0-2.9d1f509. [phases]: Use gexps. [license]: Correct to gpl3+. Change-Id: I81824de94d168e63e0434149805708cb1e8b8a54 2024-10-07gnu: jstest-gtk: Mention this is for joydev devices in description.Maxim Cournoyer * gnu/packages/games.scm (jstest-gtk) [synopsis]: Mention this is for Joydev joysticks. [description]: Likewise. Change-Id: I3a93a237ea5e2efb6bc49e6a9eee2e8714e25bf5 2024-09-29gnu: Add xevil.Tobias Geerinckx-Rice * gnu/packages/games.scm (xevil): New public variable. Change-Id: I86885cc816685001a7d8d7dacccc396f39ddbd5f 2024-09-29gnu: gzdoom: Delete files that might prevent commercial distribution.Tobias Geerinckx-Rice * gnu/packages/games.scm (gzdoom)[source]: Delete files in the snippet. Change-Id: I601bb251e9b690e375f707786bb5789a6a664b92 2024-09-29gnu: gzdoom: Update package style.Tobias Geerinckx-Rice * gnu/packages/games.scm (gzdoom)[source]: Don't explicitly return #t from snippet. [arguments]: Likewise from phases. Use G-expressions. Use SEARCH-INPUT-FILE so that we can… [inputs]: …remove input labels. Change-Id: I8dfc4ce55c1c5b5bfda98d81ba54e310b7469766 2024-10-04gnu: moonlight-qt: Update to 6.1.0.dan * gnu/packages/games.scm (moonlight-qt): Update to 6.1.0. (moonlight-common): Update to submodule checkout. Change-Id: Ia709bcf9684d843f9b24d6a8afd184a79afb1c73 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> 2024-10-01gnu: Add AntiMicroX.Eric Bavier * gnu/packages/games.scm (antimicrox): New variable. Change-Id: Ie159edf259bba0aa06ff60c074fec4457b409d12 2024-09-22gnu: Add sdl-jstest.Maxim Cournoyer * gnu/packages/games.scm (sdl-jstest): New variable. Change-Id: I8a2845375501ddadca2eb4add869fce1dc277568 2024-09-22gnu: Add evtest-qt.Maxim Cournoyer * gnu/packages/games.scm (evtest-qt): New variable. Change-Id: Ifccb54509b4469c923126b100094e06e93383208 2024-09-21gnu: Add gemrb-0.9.3.Ashvith Shetty * gnu/packages/games.scm (gemrb-0.9.3): New variable. * gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: Ic05eacf362f9a4ebfe88b1e0967e72e824c4f404 Signed-off-by: Andreas Enge <andreas@enge.fr> 2024-09-08gnu: apricots: Update to 0.2.8.Tobias Geerinckx-Rice * gnu/packages/games.scm (apricots): Update to 0.2.8. [inputs]: Replace freealut with alure. Change-Id: I3923bbef1a22c9109bda496d76451c03e98e503c 2024-09-08gnu: apricots: Disable tests.Tobias Geerinckx-Rice * gnu/packages/games.scm (apricots)[arguments]: Disable #:tests?. [native-inputs]: Remove cppcheck. Change-Id: I50e7ae3f8e41ffc415d19055e096f3538ada94a2 2024-09-08gnu: armagetronad: Update to 0.2.9.2.3.Tobias Geerinckx-Rice * gnu/packages/games.scm (armagetronad): Update to 0.2.9.2.3. [arguments]: Add a new 'omit-broken-symlinks phase. Change-Id: I2283e27facdccfb28034434253a2a3b079ceb4c4 2024-09-08gnu: armagetronad: Don't nest everything under games/.Tobias Geerinckx-Rice * gnu/packages/games.scm (armagetronad)[arguments]: Add ‘--disable-games’ to #:configure-flags. Change-Id: Ie78ed82ff01ad5e14490436169c432160dcbbe0e 2024-09-08gnu: armagetronad: Omit uninstaller.Tobias Geerinckx-Rice * gnu/packages/games.scm (armagetronad)[arguments]: Add ‘--disable-uninstall’ as #:configure-flags. Change-Id: I083108c9ba612c9a8342157c8774177f16a88a76 2024-09-08gnu: abbaye: Update to 2.0.2.Tobias Geerinckx-Rice * gnu/packages/games.scm (abbaye): Update to 2.0.2. [source]: Remove obsolete snippet. Change-Id: Id28b0c695019e4db28f3bf8defa984ec9ef5545d 2024-09-08gnu: abbaye: Update package style.Tobias Geerinckx-Rice * gnu/packages/games.scm (abbaye)[source]: Don't explicitly return #t from snippet. In-line trivial comment. [arguments]: Unquote list and use G-expressions. Change-Id: Ia5fdfa7e047f4b3bdcd166aea6a1367414073a8a 2024-09-11Update vcmi to 1.5.7.Vagrant Cascadian [[PGP Signed Part:No public key for DC518FC87F9716AA created at 2024-09-10T13:50:15+0900 using EDDSA]] The attached patch updates vcmi to 1.5.7 and works with QT6 instead of QT5 (maybe due to fixes in vcmi, maybe due to core-updates merge). Did more play testing that I had planned... live well, vagrant [2. text/x-diff; 0001-gnu-vcmi-Update-to-1.5.7.patch] From 72c5e9e79d7f9b51508c97d5d9d3b5fda7e02a0f Mon Sep 17 00:00:00 2001 From: Vagrant Cascadian <vagrant@debian.org> Date: Mon, 9 Sep 2024 17:02:02 -0700 Subject: [PATCH] gnu: vcmi: Update to 1.5.7. * gnu/packages/games.scm (vcmi): Update to 1.5.7. [native-inputs]: Use qtbase and qtools instead of the QT5 variants. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2024-09-10gnu: minetest: Update to 5.9.0.Jan Wielkiewicz The Minetest engine and the "Minetest Game" have been decoupled upstream in Minetest 5.9.0: https://dev.minetest.net/Changelog#Minetest_Game * gnu/packages/minetest.scm (minetest): Update to 5.9.0. [arguments]: Adjust #:configure-flags and #:phases to account for the removal of the Minetest Game from the Minetest codebase. [native-search-paths, synopsis, description]: Likewise. [inputs]: Remove IRRLICHT-FOR-MINETEST. (minetest-data): Update to 0.0.0-0.88ecab3. Rename to MINETEST-GAME and deprecate MINETEST-DATA. [synopsis, description]: Adjust to account for the decoupling of the game from the engine. * gnu/packages/games.scm (irrlicht-for-minetest): Remove variable. * guix/build-system/minetest.scm (default-minetest-game): New variable. (%default-modules): Use it. Change-Id: I0117bd33a2ce5eb1c79fdb29878682081f61dd4e Signed-off-by: Leo Famulari <leo@famulari.name> 2024-09-02gnu: retux: Update to 1.6.2.宋文武 * gnu/packages/games.scm (retux): Update to 1.6.2. Change-Id: Ic90a81d1cd1b961be1080dae7d482ba2cb0f03d6 2024-08-31gnu: openclonk: Use gexps and new input style.Adam Faiz * gnu/packages/games.scm (openclonk)[arguments]: Use gexps. [source]: Reindent. [inputs, native-inputs]: Drop labels. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-08-31gnu: openclonk: Fix build.Adam Faiz * gnu/packages/games.scm (openclonk): Fix build. [source]<snippet>: Unbundle dependencies and include the <limits> header where necessary to fix the build. [arguments]<#:phases>: Remove workarounds for bundled backward-cpp. [inputs]: Remove dependencies for bundled backward-cpp. Add libb2, pcg-cpp, and c-template-sort. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>