;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017, 2018, 2019, 2020 Ludovic Courtès ;;; Copyright © 2018 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (test-pack) #:use-module (guix scripts pack) #:use-module (guix store) #:use-module (guix derivations) #:use-module (guix profiles) #:use-modu
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 92ea03f9ee..a1893b3930 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4495,13 +4495,13 @@ t-probabilities, quantiles, random deviates and densities.")
(define-public r-matrixstats
(package
(name "r-matrixstats")
- (version "1.3.0")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (cran-uri "matrixStats" version))
(sha256
(base32
- "0ni4jgw3jfbwakzrcz6jcjr1zsnaq924jz2a9d8kq92vv43ycgj1"))))
+ "04kxb3ibnip0c28vrsw61q5i0yjvsh6zpalii7bhjz3zvkb1b9im"))))
(properties `((upstream-name . "matrixStats")))
(build-system r-build-system)
(arguments
-assertm "self-contained-tarball + localstatedir, UTF-8 file names" store (mlet* %store-monad ((guile (set-guile-for-build (default-guile))) (tree (interned-file-tree `("directory-with-utf8-file-names" directory ("α" regular (data "alpha")) ("λ" regular (data "lambda"))))) (tarball (self-contained-tarball "tar-pack" tree #:localstatedir? #t)) (check (gexp->derivation "check-tarball" (with-extensions (list guile-sqlite3 guile-gcrypt) (with-imported-modules (source-module-closure '((guix store database))) #~(begin (use-modules (guix store database) (rnrs io ports) (srfi srfi-1)) (define (valid-file? basename data) (define file (string-append "./" #$tree "/" basename)) (string=? (call-with-input-file (pk 'file file) get-string-all) data)) (setenv "PATH" (string-append #$%tar-bootstrap "/bin")) (system* "tar" "xvf" #$tarball) (sql-schema #$(local-file (search-path %load-path "guix/store/schema.sql"))) (with-database "var/guix/db/db.sqlite" db ;; Make sure non-ASCII file names are properly ;; handled. (setenv "GUIX_LOCPATH" #+(file-append glibc-utf8-locales "/lib/locale")) (setlocale LC_ALL "en_US.utf8") (mkdir #$output) (exit (and (every valid-file? '("α" "λ") '("alpha" "lambda")) (integer? (path-id db #$tree))))))))))) (built-derivations (list check)))) (unless store (test-skip 1)) (test-assertm "docker-image + localstatedir" store (mlet* %store-monad ((guile (set-guile-for-build (default-guile))) (profile (profile-derivation (packages->manifest (list %bootstrap-guile)) #:hooks '() #:locales? #f)) (tarball (docker-image "docker-pack" profile #:symlinks '(("/bin/Guile" -> "bin/guile")) #:localstatedir? #t)) (check (gexp->derivation "check-tarball" (with-imported-modules '((guix build utils)) #~(begin (use-modules (guix build utils) (ice-9 match)) (define bin (string-append "." #$profile "/bin")) (setenv "PATH" (string-append #$%tar-bootstrap "/bin")) (mkdir "base") (with-directory-excursion "base" (invoke "tar" "xvf" #$tarball)) (match (find-files "base" "layer.tar") ((layer) (invoke "tar" "xvf" layer))) (when (and (file-exists? (string-append bin "/guile")) (file-exists? "var/guix/db/db.sqlite") (file-is-directory? "tmp") (string=? (string-append #$%bootstrap-guile "/bin") (pk 'binlink (readlink bin))) (string=? (string-append #$profile "/bin/guile") (pk 'guilelink (readlink "bin/Guile")))) (mkdir #$output))))))) (built-derivations (list check)))) (unless store (test-skip 1)) (test-assertm "squashfs-image + localstatedir" store (mlet* %store-monad ((guile (set-guile-for-build (default-guile))) (profile (profile-derivation (packages->manifest (list %bootstrap-guile)) #:hooks '() #:locales? #f)) (image (squashfs-image "squashfs-pack" profile #:symlinks '(("/bin" -> "bin")) #:localstatedir? #t)) (check (gexp->derivation "check-tarball" (with-imported-modules '((guix build utils)) #~(begin (use-modules (guix build utils) (ice-9 match)) (define bin (string-append "." #$profile "/bin")) (setenv "PATH" (string-append #$squashfs-tools "/bin")) (invoke "unsquashfs" #$image) (with-directory-excursion "squashfs-root" (when (and (file-exists? (string-append bin "/guile")) (file-exists? "var/guix/db/db.sqlite") (string=? (string-append #$%bootstrap-guile "/bin") (pk 'binlink (readlink bin))) ;; This is a relative symlink target. (string=? (string-drop (string-append #$profile "/bin") 1) (pk 'guilelink (readlink "bin")))) (mkdir #$output)))))))) (built-derivations (list check))))) (test-end) ;; Local Variables: ;; eval: (put 'test-assertm 'scheme-indent-function 2) ;; End: