aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm58
1 files changed, 50 insertions, 8 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index ff39aea9ba..92a3e201e5 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -18,6 +18,10 @@
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Wojtek Kosior <koszko@koszko.org>
+;;; Additions and modifications by Wojtek Kosior are additionally
+;;; dual-licensed under the Creative Commons Zero v1.0.
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,6 +44,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -57,6 +62,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -68,6 +74,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages security-token)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg)
@@ -198,7 +205,7 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "9.7p1")
+ (version "9.8p1")
(source
(origin
(method url-fetch)
@@ -206,7 +213,7 @@ a server that supports the SSH-2 protocol.")
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-trust-guix-store-directory.patch"))
(sha256
- (base32 "1z9zfw7ndibxwprazlkv1isrh1yplczdin5cziijfanqcvvjc129"))))
+ (base32 "1wrrb8zrfj9wa9nbpx310kl2k05gm4gxsl5hvycx9dbrlc1d12yx"))))
(build-system gnu-build-system)
(arguments
(list
@@ -490,7 +497,8 @@ with optional @acronym{TLS, Transport-Level Security} to protect credentials.")
(native-inputs
(list pkg-config))
(inputs
- (list boost
+ (list bash-minimal
+ boost
ncurses
openssl
perl
@@ -509,7 +517,7 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
(define-public dropbear
(package
(name "dropbear")
- (version "2022.83")
+ (version "2024.85")
(source
(origin
(method url-fetch)
@@ -517,7 +525,7 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
"https://matt.ucc.asn.au/dropbear/releases/"
"dropbear-" version ".tar.bz2"))
(sha256
- (base32 "0fs495ks354qcfj4k5bwg6m50vbl8az03gjymmqm2jy9zcgi4nmw"))
+ (base32 "00m5dmajx0za1zmya4qdz763hxy4cmfk7bpba778k7d66g23dc46"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -535,10 +543,10 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'enable-x11-forwarding
(lambda _
- (substitute* "default_options.h"
+ (substitute* "src/default_options.h"
(("#define DROPBEAR_X11FWD 0")
"#define DROPBEAR_X11FWD 1")))))))
- (inputs (list libtomcrypt libtommath zlib))
+ (inputs (list libtomcrypt libtommath libxcrypt zlib))
(synopsis "Small SSH server and client")
(description "Dropbear is a relatively small SSH server and
client. It runs on a variety of POSIX-based platforms. Dropbear is
@@ -619,7 +627,8 @@ basis for almost any application.")
;; The server (lshd) invokes xauth when X11 forwarding is requested.
;; This adds 24 MiB (or 27%) to the closure of lsh.
xauth
- libxau)) ;also required for x11-forwarding
+ libxau ;also required for x11-forwarding
+ libxcrypt))
(arguments
'(;; Skip the `configure' test that checks whether /dev/ptmx &
;; co. work as expected, because it relies on impurities (for
@@ -942,6 +951,39 @@ Ed25519 keys.
@end itemize")
(license license:expat)))
+(define-public tmate-ssh-server
+ (let ((ver "2.3.0")
+ (rev "0")
+ (commit-id "d7334ee4c3c8036c27fb35c7a24df3a88a15676b"))
+ (package
+ (name "tmate-ssh-server")
+ (version (git-version ver rev commit-id))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmate-io/tmate-ssh-server")
+ (commit commit-id)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vf9b0hlsi7wj5zqnbqph6f467mpkasaaspp80ipdmrdm2yp8yjp"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-msgpack-pkg-config-dependency
+ (lambda _
+ (substitute* "configure.ac"
+ (("msgpack >= ")
+ "msgpack-c >= ")))))))
+ (native-inputs (list autoconf automake pkg-config))
+ (inputs (list libevent libite libssh msgpack-c ncurses))
+ (home-page "https://tmate.io/")
+ (synopsis "The server side part of tmate")
+ (description "This package allows users to host their own tmate
+servers.")
+ (license license:expat))))
+
(define-public x11-ssh-askpass
(package
(name "x11-ssh-askpass")