aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm71
1 files changed, 56 insertions, 15 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a91a2d693d..647f7e71d2 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -590,7 +590,7 @@ mixed.")
(define-public chibi-scheme
(package
(name "chibi-scheme")
- (version "0.10")
+ (version "0.11")
(home-page "https://github.com/ashinn/chibi-scheme")
(source
(origin
@@ -598,7 +598,7 @@ mixed.")
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0yhmj0lws3r3bl4ivs31dhlzxqc7f0dinixi904mraz1fmrg3w7f"))))
+ (base32 "02zq35hdbi03rmmamx6ml4ihsigdl4mmbf6d9ysazv8ciiln5v4b"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -739,7 +739,7 @@ utility functions for all standard Scheme implementations.")
(define-public scm
(package
(name "scm")
- (version "5f3")
+ (version "5f4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -747,7 +747,7 @@ utility functions for all standard Scheme implementations.")
version ".zip"))
(sha256
(base32
- "1jxxlhmgal26mpcl97kz37djkn97rfy9h5pvw0hah6f3f6w49j97"))))
+ "17i6shvh2caqmksm7z130f9fz0qinaxg7xz9yadv904xh3znshnk"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1085,7 +1085,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(define-public gauche
(package
(name "gauche")
- (version "0.9.12")
+ (version "0.9.15")
(home-page "https://practical-scheme.net/gauche/index.html")
(source
(origin
@@ -1095,7 +1095,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(string-replace-substring version "." "_")
"/Gauche-" version ".tgz"))
(sha256
- (base32 "05xnym1phg8i14bacip5d0d3v0gc1nn5mgayd5hnda873f969bml"))))
+ (base32 "10zpbbikkcpdzk6c52wkckiyhn7nhnqjv2djdzyjr0n8qxxy4hrn"))))
(build-system gnu-build-system)
(inputs
(list libatomic-ops slib zlib))
@@ -1116,24 +1116,20 @@ The core is 12 builtin special forms and 33 builtin functions.")
"ext/tls/test.scm"
"lib/gauche/package/util.scm"
"libsrc/gauche/process.scm")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'build 'build-doc
(lambda _
(with-directory-excursion "doc"
- (invoke "make" "info"))
- #t))
+ (invoke "make" "info"))))
(add-before 'check 'patch-network-tests
;; Remove net checks.
(lambda _
(delete-file "test/net.scm")
- (invoke "touch" "test/net.scm")
- #t))
+ (invoke "touch" "test/net.scm")))
(add-after 'install 'install-docs
(lambda _
(with-directory-excursion "doc"
- (invoke "make" "install"))
- #t)))))
+ (invoke "make" "install")))))))
(synopsis "Scheme scripting engine")
(description "Gauche is a R7RS Scheme scripting engine aiming at being a
handy tool that helps programmers and system administrators to write small to
@@ -1290,7 +1286,7 @@ Gerbil code within Emacs.")))
(arguments
(list
#:modules `((ice-9 ftw)
- ,@%gnu-build-system-modules)
+ ,@%default-gnu-modules)
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-sh-references
@@ -1314,3 +1310,48 @@ as well as light. The implementation is based on an ad-hoc Virtual
Machine. STklos can also be compiled as a library and embedded in an
application.")
(license gpl2+)))
+
+(define-public r7rs-small-texinfo
+ (let ((commit "38a703976ea6353e32b52a5187dbdaf77fb2f050")
+ (revision "3"))
+ (package
+ (name "r7rs-small-texinfo")
+ (version (git-version "0.1.0" revision commit))
+ (home-page "https://codeberg.org/Zipheir/r7rs-small-texinfo/")
+ (source
+ (origin
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fr02fyhiwd364jkfy1n5w31pq3kx1rl5w634421g05702yb47x3"))))
+ (native-inputs (list bash texinfo))
+ (inputs '())
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan #~'(("r7rs-small.info" "share/info/"))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'compile-the-files
+ (lambda _
+ (let* ((source-directory-path (string-append (getcwd)
+ "/doc/r7rs-small"))
+ (build-script-path (string-append
+ source-directory-path
+ "/build.sh"))
+ (info-directory-path (string-append #$output
+ "/share/info")))
+ (chdir source-directory-path)
+ (system* "bash" build-script-path "info")
+ (mkdir-p info-directory-path)
+ (copy-file (string-append source-directory-path
+ "/r7rs-small.info")
+ (string-append info-directory-path
+ "/r7rs-small.info"))))))))
+ (synopsis
+ "R7RS Small standard of the Scheme programming language in Info format")
+ (description
+ "Revised^7 Report of the Algorithmic Language Scheme adapted to Texinfo format.")
+ (license (non-copyleft "file://COPYING")))))