aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 687c20cd90..37d9eb0bee 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2011,6 +2011,8 @@ compositor libraries.")))
(origin
(method url-fetch)
(uri (qt-url name version))
+ (patches (search-patches
+ "qtwayland-6-update-wayland-xml.patch"))
(sha256
(base32 "0gamcqpl302wlznfnlcg9vlnnhfpxgjnz05prwc9wpy0xh7wqvm9"))))
(build-system cmake-build-system)
@@ -2026,7 +2028,11 @@ compositor libraries.")))
(((string-append
"QVERIFY\\(!cursorSurface\\(\\)->"
"m_waitingFrameCallbacks\\.empty\\(\\)\\);")) "")
- (("QTRY_COMPARE\\(bufferSpy\\.size\\(\\), 1\\);") ""))))
+ (("QTRY_COMPARE\\(bufferSpy\\.size\\(\\), 1\\);") ""))
+ ;; known failing with wayland-1.23.0, so skip this.
+ ;; See also: <https://bugreports.qt.io/browse/QTBUG-126379>
+ (substitute* "tests/auto/client/CMakeLists.txt"
+ (("add_subdirectory\\(scaling\\)") ""))))
(add-before 'check 'set-test-environment
(lambda _
(setenv "XDG_RUNTIME_DIR" (getcwd))