aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c5cae6de45..8c86d5a768 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1571,9 +1571,9 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python2-certifi
(package-with-python2 python-certifi))
-(define-public python2-requests
+(define-public python-requests
(package
- (name "python2-requests")
+ (name "python-requests")
(version "2.4.0")
(source (origin
(method url-fetch)
@@ -1588,8 +1588,7 @@ is used by the Requests library to verify HTTPS requests.")
(inputs
`(("python-setuptools" ,python-setuptools)
("python-certifi" ,python-certifi)))
- (arguments `(#:tests? #f ; no tests
- #:python ,python-2))
+ (arguments `(#:tests? #f)) ; no tests
(home-page "http://python-requests.org/")
(synopsis "Python HTTP library")
(description
@@ -1597,6 +1596,9 @@ is used by the Requests library to verify HTTPS requests.")
than Python’s urllib2 library.")
(license asl2.0)))
+(define-public python2-requests
+ (package-with-python2 python-requests))
+
(define-public python-jsonschema
(package
(name "python-jsonschema")